I've recently installed Vim for Windows 10. After this I have installed latex-suite files in the $HOME/vimfiles/bundle directory (I'm using pathogen). I've configured my _vimrcfile as following:

execute pathogen#infect()
syntax on
filetype plugin on

set shellslash
set grepprg=grep\ -nH\ $*
set nocompatible

filetype indent on

let g:tex_flavor='latex'

When running :scriptnames I can see that the latex scripts are being loaded, but the Tex-Suite menu is not showing up in gvim. I have looked around a tried different solutions, but they have not worked.

Any ideas?

  • Welcome to TeX.SX! let g:text_flavor='latex' should be let g:tex_flavor='latex' I'm pretty sure and you should have filetype plugin on somewhere in there, I'm not sure that filetype plugin indent on has the same effect and you may advise need something like set nocompatible. Can't check my own setup to recall if there's anything else essential, vim-LaTeX has quite good documentation, have you checked the manual?
    – Dai Bowen
    Jan 25, 2017 at 19:37
  • I did check the manual but I was probably a bit too tired when writing the vimrc file. I have edited my original question with the new file, but the problem still remains, no Tex-Suite menu or TTemplate command. Jan 25, 2017 at 20:32
  • 1
    So nothing like compiling a tex file with \ll and the F5/F7 keys function as expected? vim-LaTeX tends only to get loaded with files that have already been saved as tex files as far as I have experienced incase that is of use? Could you share the results of :scriptnames here?
    – Dai Bowen
    Jan 25, 2017 at 21:24
  • @Dai Bowen Aaah, yes! Thank you! It didn't work when creating a new file within Vim, but when opening an already existing .tex file the plugin seems to have been loaded. Thank you! Jan 26, 2017 at 8:14

1 Answer 1


Thanks to Dai Bowen in the comments, I was able to find the problem. It seems like the Vim-Latex plugin only loads once you open an already existing .tex file, not when one is created in Vim.

I simply created a new file and saved it as a .tex file and then reopened it.

  • So how did u compile the file @Dramentiaras ?. I mean u save with ':w' and then ?
    – Ruffnǝck
    Sep 2, 2020 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .