1

This code:

\documentclass{book}
\usepackage[margin]{fixme}
\fxsetup{theme=color}

\begin{document}    
    Duck\fxnote{quack}
\end{document}

gives me this error:

! LaTeX Error: File `fxthemecolor.sty' not found.

(but it worked till few days ago).

I tried to uninstall and re-install fixme package with MiKTeX but it doesn't change anything.

  • I don't have this problem with overleaf online TeX editor. – Jérôme Dequeker Jan 26 '17 at 8:37
  • 1
    @JérômeDequeker Maybe it's a MiKTeX problem, I've added the tag. – CarLaTeX Jan 26 '17 at 9:09
  • Have you tried to update MiKTeX and all the packages ? – Jérôme Dequeker Jan 26 '17 at 9:33
  • @JérômeDequeker overleaf might not be using bleeding edge. And fixme was just updated for the first time in a few years. That being said, my fully up to date TeX Live 2016 has no problems. – daleif Jan 26 '17 at 9:47
  • 1
    @daleif I tried to unistall the one-person version of MiKTeX and install the version with admin but I didn't solve the problem. Eventually, I installed TeX Live 2016 and all works well. – CarLaTeX Jan 28 '17 at 7:59
2

as far as I can tell, this is a MiKTeX problem. I'm not familiar with this distribution but this page seems to indicate that it's currently missing the targets and layouts subdirectories. Maybe you could confirm this by running

ls -R `dirname \`kpsewhich fixme.sty\``

I'm using the MacTeX TeXlive distribution, and as of this morning, it works fine. As an emergency solution, you could install FiXme by hand locally. For that, you may:

  1. download the tarball from here (or browse CTAN), unpack and follow the instructions in the README[.md] file, or even simpler,
  2. get the bleeding edge version:

git clone https://github.com/didierverna/fixme.git; cd fixme; make install

Hope this helps,

  • Thank you for your answer! Unfortunately, in the meantime I switched to TeX Live, hence I can't test your solution... – CarLaTeX Feb 1 '17 at 9:08
  • 1
    If you are in pressing need of the package then naturally a manual download is necessary. But in other case it is much better to make a bug report at the miktex bug tracker. – Ulrike Fischer Feb 1 '17 at 9:35
  • 1
    As @UlrikeFischer correctly pointed out ls is not a Windows command, the corresponding one is dir... – CarLaTeX Feb 1 '17 at 14:05
4

It is a miktex problem. Some files are missing in the package. This can (and did) happen in miktex and in texlive. Packaging can go wrong in various ways. It e.g. also can happen that files ends up in the wrong folder, e.g. a needed file in the doc-folder.

In miktex you can see the content of a package by going to the package manager, selecting the package and choosing "properties" in the context menu.

In tlmgr you can see it with tlmgr info <package> --list.

If you suspect a packaging error you can then compare the file list e.g. with the documentation or the README of the package on CTAN.

If you are in pressing need to use the package you can always download the files from CTAN and move them e.g. in your document folder. Beside this you should inform the maintainer of the tex system about the error. For miktex through the bug tracker https://sourceforge.net/p/miktex/bugs/, for texlive by writing to the mailing list.

In this case I added an entry for fixme https://sourceforge.net/p/miktex/bugs/2572/

  • I didn't thought to install the package manually! However, I already wanted to switch to TeX Live because it is managed by the TUG. I'm going to accept the other answer because he arrived first... – CarLaTeX Feb 1 '17 at 10:12
  • 1
    Well I'm not sure if miktex (and so windows users) can do much with the advice to run ls -R. – Ulrike Fischer Feb 1 '17 at 10:39
  • I'll write in a comment to his answer to use dir... – CarLaTeX Feb 1 '17 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.