1

This question already has an answer here:

How to modify the subcaption "Figure 1a" to "Figure 1 (a)"?

\documentclass[12pt]{article}
\usepackage{blindtext}
\usepackage{graphicx,psfrag,epsf}
\usepackage{epstopdf}

\usepackage{float}
\usepackage[export]{adjustbox}
\usepackage{mathtools}
\usepackage{verbatim}

%\usepackage[subrefformat=parens,labelformat=parens, labelsep=quad]{subfig}
\usepackage{subfigure}
\usepackage{caption}
%\usepackage{subcaption}
\newcommand{\bs}{\boldsymbol}
\renewcommand\thesubfigure{\alph{subfigure}}

% correct bad hyphenation here

%\pdfminorversion=4
% NOTE: To produce blinded version, replace "0" with "1" below.
\newcommand{\blind}{0}

% DON'T change margins - should be 1 inch all around.
\addtolength{\oddsidemargin}{-.5in}%
\addtolength{\evensidemargin}{-.5in}%
\addtolength{\textwidth}{1in}%
\addtolength{\textheight}{-.3in}%
\addtolength{\topmargin}{-.8in}%

\begin{document}

The Figure~\ref{descriptive1} is composed by Figure~\ref{fig:hist_longair} and Figure~\ref{fig:curve_longair}.

\begin{figure}[H]
    \center
    \subfigure[Histogram]{\includegraphics[width = .42\linewidth]{hist_longair.eps} \label{fig:hist_longair}}%
    \quad%
    \subfigure[Contour curve]{\includegraphics[width = .42\linewidth]{curve_longair.eps}\label{fig:curve_longair}}%
    \caption{Histogram, contour curve and symbolic scatterplot of $\bs{Y}$} 
    \label{descriptive1}
\end{figure}
\end{document}

marked as duplicate by Community Jan 27 '17 at 6:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    The subfigure package is deprecated. Use subfig or subcaption instead. – Mico Jan 27 '17 at 4:00
  • But this don't resolve the problem. – Wagner Jorge Jan 27 '17 at 4:57
2

The subfigure package is both deprecated and quite incompatible with the caption package, which is also loaded by your document. I suggest you ditch loading the subfigure package and, instead, load the subcaption package and make use of its machinery. (The subcaption package automatically loads the caption package too.)

A separate advantage of this approach is that it lets you use the cleveref package and its "clever" cross-referencing commands. An application is shown in the example below.

I've interpreted your write-up as wanting some whitespace between the figure label and the subfigure label. This is implemented by having \, (thinspace) in the (re)definition of \thesubfigure. If you would rather have a full interword space, simply replace \, with ~ (non-breaking space). I wouldn't recommend this, though; in fact, if this were my document, I wouldn't provide any space at all.

enter image description here

\documentclass[12pt]{article}
% I've tried to slim the preamble down to the essentials.
\usepackage{mathtools}
\let\bs\boldsymbol
\usepackage[demo]{graphicx} % remove 'demo' option in real document

\usepackage[labelformat=simple]{subcaption} % default is 'labelformat=parens'
\renewcommand\thesubfigure{\,(\alph{subfigure})} % thinspace before subfigure label

\usepackage[noabbrev]{cleveref} % just for this example

\begin{document}
Figure~\ref{descriptive1} consists of Figure~\ref{fig:hist_longair} and Figure~\ref{fig:curve_longair}.

\Cref{descriptive1} consists of \Cref{fig:hist_longair,fig:curve_longair}.

\begin{figure}[ht!]

\begin{subfigure}{.45\textwidth}
\includegraphics[width=\linewidth]{hist_longair.eps}
\caption{Histogram}\label{fig:hist_longair}
\end{subfigure}
\hfill % maximize the spread between the subfigures
\begin{subfigure}{.45\textwidth}
\includegraphics[width=\linewidth]{curve_longair.eps}
\caption{Contour curve}\label{fig:curve_longair}
\end{subfigure}

\caption{Histogram, contour curve and symbolic scatterplot of $\bs{Y}$} 
\label{descriptive1}
\end{figure}

\end{document}

Not the answer you're looking for? Browse other questions tagged or ask your own question.