2

It is the first time I am trying to include the bibliography with biber in a Beamer presentation, and I am clueless on how to change the style and get rid of some fields. I tried with a custom .bst file I obtained with makebst but biber does not seem to understand it...

So here is my MWE:

\documentclass{beamer}
\setbeameroption{hide notes}

\usepackage{lmodern}

\usepackage[backend=biber, style=authoryear]{biblatex}
\begin{filecontents}{\jobname.bib}
@article{Forrest2014,
    author = {Forrest, Alistair R. R. and Kawaji, Hideya and Rehli, Michael and {Kenneth Baillie}, J. and de Hoon, Michiel J. L. and Haberle, Vanja and Lassmann, Timo},
    doi = {10.1038/nature13182},
    issn = {0028-0836},
    journal = {Nature},
    pages = {462--470},
    pmid = {24670764},
    title = {{A promoter-level mammalian expression atlas}},
    url = {http://dx.doi.org/10.1038/nature13182{\%}5Cnhttp://www.nature.com/doifinder/10.1038/nature13182},
    volume = {507},
    year = {2014}
}
\end{filecontents}
\addbibresource{\jobname.bib}
\setbeamertemplate{bibliography item}{}

\mode<presentation> {
    \usetheme{Singapore}
}
\begin{document}


\section{Frame 1}
\begin{frame}
\frametitle{Frame 1}
    Here I want a citation:

    \cite{Forrest2014}
\end{frame}


\begin{frame}[allowframebreaks]
\frametitle{References}
    \printbibliography
\end{frame}


\end{document}

Which produces the following:

a b

What I would like to accomplish is the following:

  • First of all, get rid of the following warnings:

Patching footnotes failed.

and

Font shape OT1/lmss/m/sc' in size <10.95> not available(Font) Font shapeOT1/lmr/m/sc' tried instead

I also encounter the following one in my full presentation:

Font shape EU2/lmss/m/sc' in size <10.95> not available(Font) Font shapeEU2/lmr/m/sc' tried instead

Then I want to customize the citations in this way:

  • "et al" in italics, in both places

  • Only initial for first names

  • Year at the end

  • No "In: "

  • No DOI, ISSN, URL or anything like that

The result should be as close as possible to:

Forrest et al. 2014

and

Forrest ARR et al. “A promoter-level mammalian expression atlas”. Nature 507:462–470 (2014).

What do the warnings mean and how to get rid of them? I already used \lmodern...

How can I customize bibliography with biber, when it does not accept .bst files from makebst?

Many thanks!

3

Summing up the duplicates:

  • First of all, get rid of the warnings

The footnote warning is normal as beamer has its own way to deal with footnotes, see Beamer patching footnotes warning: "Patching footnotes failed. Footnote detection will not work."

  • "et al" in italics, in both places

https://tex.stackexchange.com/a/40999/36296

  • Only initial for first names

https://tex.stackexchange.com/a/128823/36296

  • Year at the end

changing the order of the fields can be found at Biblatex: changing the order of entries and Biblatex: changing the order of entries and Changing order of fields and suppressing extra arXiv identifiers and Biblatex: Change order of fields (note+pages) for inproceedings/incollection

  • No "In: "

Suppress "In:" biblatex

  • No DOI, ISSN, URL or anything like that

Biblatex: Get rid of ISSN, URLs and DOIs in references


\documentclass{beamer}
\setbeameroption{hide notes}

\usepackage{lmodern}

\usepackage[backend=biber, style=authoryear, doi=false,isbn=false,url=false, giveninits=true]{biblatex}
\begin{filecontents}{\jobname.bib}
@article{Forrest2014,
    author = {Forrest, Alistair R. R. and Kawaji, Hideya and Rehli, Michael and {Kenneth Baillie}, J. and de Hoon, Michiel J. L. and Haberle, Vanja and Lassmann, Timo},
    doi = {10.1038/nature13182},
    issn = {0028-0836},
    journal = {Nature},
    pages = {462--470},
    pmid = {24670764},
    title = {{A promoter-level mammalian expression atlas}},
    url = {http://dx.doi.org/10.1038/nature13182{\%}5Cnhttp://www.nature.com/doifinder/10.1038/nature13182},
    volume = {507},
    year = {2014}
}
\end{filecontents}
\addbibresource{\jobname.bib}
\setbeamertemplate{bibliography item}{}

\usepackage{xpatch}

\xpatchbibmacro{name:andothers}{%
  \bibstring{andothers}%
}{%
  \bibstring[\emph]{andothers}%
}{}{}

\renewbibmacro{in:}{}

\mode<presentation> {
    \usetheme{Singapore}
}
\begin{document}


\section{Frame 1}
\begin{frame}
\frametitle{Frame 1}
    Here I want a citation:

    \cite{Forrest2014}
\end{frame}


\begin{frame}[allowframebreaks]
\frametitle{References}
    \printbibliography
\end{frame}


\end{document}

enter image description here

  • Thanks Sam! I was starting to figure it out and was going to post an edit... the font warnings seem to have to do with the way DOI, ISSN, etc are printed, so when setting them to false, those warnings go away... – DaniCee Jan 29 '17 at 14:02
  • So as I have it now, the only problem is the footnote warning... Can it be safely ignored? – DaniCee Jan 29 '17 at 14:03
  • @DaniCee To my knowledge: yes – samcarter_is_at_topanswers.xyz Jan 29 '17 at 14:05
  • Sorry I will tend to split up my questions and look deeper into each individual problem before posting... – DaniCee Jan 30 '17 at 3:39
  • in the link you provide for the footnotes warning, they mention it can be solved by changing an .sty file... I use my own beamer theme with my own .sty file, do you know what should be changed in there? Thanks! – DaniCee Jan 30 '17 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.