3

I have recently installed the Latex distribution MacTeX-2016. Since then, I cannot compile some of my KOMA-script files. The problem occurs only with the files where I use the KOMA-script classes. Also, the very same KOMA-script files used to compile perfectly fine before I installed this new Latex distribution. I attach here a screen shot of an example of an error message I am getting, in a file that used to compile perfectly fine before the update. Here I use the environment:

\begin{enumerate}[-]
\end{enumerate}

error message with enumerate And here another example with an accent, which I used not to have also: error message with an accent I would be very grateful if someone could help me curing that problem.

I am not sure I should answer your reply here, since it's the first time I using tex.stackexchange, but I try here...

Thank you very much for your answer, which is very helpful. Thanks to you, I identified a bit better the issue: The problem seems to come from that command:

\selectlanguage{french}

which I have in my list of packages, after the package you mention, namely

\usepackage{enumerate}

If I have the \selectlanguage{french} command, I get the error I was mentioning, even when the command \usepackage{enumerate} is there. If I do not have the \selectlanguage{french} command, then everything works fine, as you indicated. But I don't get it, since it used to work even with that command before my update... Also I don't get the reason of the interference between the two packages...

Also, I am not sure whether I need the package \selectlanguage{french} or not, since this was a template for a French document that I inherited from someone.

About the \rm command, screening the internet, I read that putting:

\DeclareOldFontCommand{\rm}{\normalfont\rmfamily}{\mathrm}

could rescue these old commands, no longer supported apparently. But even introducing that does not seem to work. This said, you are right that $i$\textsuperscript{i\eme}` cures the problem, and is probably better to use. I just need now to change in all my files.

Anyway, please find here my minimal example as you requested, which compiles fine without the \selectlanguage{french} command, and does not compile with it, which is strange to me. Is that normal?

\documentclass[a4paper,12pt,french,DIV=calc,twoside,openright,chapterprefix]{scrreprt}

\usepackage[utf8]{inputenc}

\usepackage[francais]{babel}

\usepackage{lmodern}

\usepackage{microtype}

\usepackage{enumerate}

\selectlanguage{french}

\begin{document}

Les deux op\'erations suivantes peuvent s'effectuer sur les vecteurs:

\begin{enumerate}[-]

\item multiplication par un nombre r\'eel...

\item somme de deux vecteurs de m\^eme origine~: ...

\end{enumerate}

\end{document}
  • 1
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – DG' Feb 3 '17 at 23:07
  • Have you updated the distribution since installation? There have been many updates to the TeX Live distribution since it was released. Use the TeX Live Utility to do the update. That app can be found in the /Applications/TeX folder. – Herb Schulz Feb 4 '17 at 4:43
  • you need to specify french (and have \usepackage[T1]{fontenc} if your text is french (otherwise hyphenation will be all wrong, and fixed texts like "table of contents" will be in English not French) – David Carlisle Feb 5 '17 at 13:25
5

If I complete your fragment into a koma-script document

\documentclass{scrartcl}

\begin{document}
\begin{enumerate}[-]
\item multiplication par  un\ldots
\end{enumerate}
\end{document}

Then it generates the error shown in your question

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.5 \item m
           ultiplication par  un\ldots
? 

It would always have done this, not a change in some recent update.

There are two common packages that give enumerate an optional argument, if I add

\usepackage{enumitem}

Then the error changes to

! Package enumitem Error: - undefined.

If I change it to

\usepackage{enumerate}

Then the document runs without error but with the warning

LaTeX Warning: The counter will not be printed.
             The label is: - on input line 4.

Which means that the option has essentially made enumerate into itemize and produces

enter image description here

with - as an item bullet.


Note the other error you show (unfortunately again just as an image not as text) is from

$i^{\rm i\`eme}$

\rm has not been defined by default in latex since latex2e released in 1993, so its use has always been deprecated, and recent KOMA classes stopped defining it so you should now get an undefined command error from \rm (which would be a change if you have not updated recently).

However whether or not \rm is defined, \`e would always have given an error in math mode as shown in your image.

The error text suggests using a math accent but here the use is not mathematical so better would be

$i$\textsuperscript{i\`eme}
| improve this answer | |
  • Thank you very much for your answer, which is very helpful. – Thomas921 Feb 5 '17 at 12:16
  • Thank you very much. I posted a more complete reply below, as an 'answer' to my own question, since I would not know how to reply to you otherwise... – Thomas921 Feb 5 '17 at 12:49
  • Thank you very much. I posted update to my original question, to reply to your answer and give you more details. Apparently I cannot reply to you using a new post, I don't really master the way tex.stackexchange works yet ;-) – Thomas921 Feb 5 '17 at 12:58
  • 1
    @Thomas921 the babel french package (for some reason) completely redefines the enumerate environment so the behaviour reverts to the standard definition and you get an error for the optional argument. I'm not sure why but it appears to be an intentional change. – David Carlisle Feb 5 '17 at 13:31
  • @Davide Carlisle Thank you very much. This is perfectly clear. I do not really understand the logic behind that, but the important thing is that I know how to handle this issue. Thank you very much for your help! – Thomas921 Feb 7 '17 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.