50

I have downloaded MiKTeX (on Windows 10). The .tex files for papers and posters compile well but beamer does not work.

Here is the header of my .tex file:

\documentclass[10pt]{beamer}
%
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{fancybox}
\usepackage{amssymb}  %   MATH
\usepackage{amsmath}  %   MATH
\usepackage{latexsym} %   MATH
\usepackage{amsthm}   %   MATH
\usepackage[italian,english]{babel}
\usepackage{bm}         % per scrivere in grassetto i caratteri matematici
\usepackage{indentfirst}
\usepackage{color}
\usepackage{booktabs}
\usepackage{graphicx}
\usepackage{multimedia}
\usepackage{eurosym}
\usepackage{tikz}

I receive the following error message:

! Undefined control sequence. 
l.1 \beamer@endinputifotherversion
                                   {3.26pt}

How can this problem be fixed?

Joab Winkler

0

1 Answer 1

81

You've changed beamer versions and not deleted you auxiliary files. Older versions of beamer add \beamer@endinputifotherversion to the .nav and .toc files to check for version changes. This was removed in recent versions as it tends to cause more trouble than it fixes. As such, you can either

  • Just press Return and let the run continue or
  • Delete the .nav and .toc files

In either case, the issue will disappear at the next run.

4
  • Hi @Joseph Wright. I did both of the above it refused to work. I have mac laptop with version 2.2.16 (where the tex file runs without any issue) and a windows version 2.2.16 (where it refuses to work). Do you know what might be the problem? Thanks, Nishant. Aug 28, 2019 at 11:42
  • @NishantChandgotia I have no idea what version number you are referring to: current beamer is 3.56!
    – Joseph Wright
    Aug 29, 2019 at 6:10
  • Maybe that is the issue. I have 2018/12/02 v3.55. I tried updating it but I am somehow unable to do that. Sep 1, 2019 at 13:26
  • FWIW, this answer worked great for me. Beamer version 3.40 (Debian 9/Stretch).
    – Digger
    Jul 20 at 20:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.