0
 \node[text width=3cm,rotate=90] at ([shift={(0ex, 0x)}] pic cs:fig1) {{\tiny{First\\Line}}};  

Either setting the width to be small or using \\ will split the text but it has a huge gap between First and Line. Enough to stick my thumb between them. It's as if whatever space would be used with \tiny is being used. I want the gap between the two lines to be almost nil. I could use another node and position it but that seems like overkill.

  • the baseline skip is a property of the paragraph and in your fragment the scope of \tiny has finished before the paragraph ends so you will get tiny text on a normal baseline. – David Carlisle Feb 5 '17 at 16:07
4

It seems that your example works just fine if you change \tiny to the option font=\tiny. That corrects the baselines.

The compiled example

\documentclass[tikz]{standalone}
\begin{document}
 \tikz \node[text width=3cm,rotate=90,font=\tiny] at (0,0) {{First\\Line}};  
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.