0

I'm trying to write the "power of a set" in LaTeX, but I don't think that the usual ways to do it look like the handwritten letter (I usually write it as \mathcal{P}, but would like to find another way). Someone answered here, in another context, with an option I would like to use: \euscr{P}, but for some reason I can't quite understand, it doesn't work for me, and looks exactly like \mathcal{P}. Can someone help me to make this work? I think the problem is somewhere in my preamble, maybe conflicting packages? Here is a minimal (non)working example:

    \documentclass[a4paper,12pt]{article}
    \usepackage[spanish,activeacute]{babel}
    \usepackage{amsmath}
    \usepackage{latexsym}
    \usepackage{dsfont}
    \usepackage{float}
    \usepackage{gensymb}
    \usepackage[left=2.1 cm,top=2.3 cm,right=2.3 cm,bottom=2.5cm]{geometry} 
    \usepackage{amssymb}
    \usepackage[utf8]{inputenc}
    \usepackage[justification=centering]{caption}
    \usepackage{amssymb}
    \usepackage{authblk}
    \usepackage{graphicx}
    \usepackage{enumitem}
    \usepackage{resizegather}
    \usepackage{color}
    \usepackage{amstext}
    \usepackage{subcaption}
    \usepackage{amsfonts}
    \usepackage{amsthm}
    \usepackage[dvips]{epsfig}
    \usepackage{doc}
    \usepackage{mathtools}
    \usepackage{upgreek}
    \usepackage{setspace}
    \usepackage{titling}
    \usepackage{textcomp}
    \usepackage{wasysym}
    \usepackage{bm}
    \usepackage{stmaryrd}
    \usepackage[hidelinks,colorlinks=true,linkcolor=blue]{hyperref}
    \hypersetup{colorlinks,linkcolor=[rgb]{0.6,0.2,0.8}}
    \usepackage[hyphenbreaks]{breakurl}
    \usepackage{tocloft}
    \renewcommand{\cftsecleader}{\cftdotfill{\cftdotsep}}
    \usepackage[dvipsnames]{xcolor}
    \usepackage[mathscr]{euscript}
    \let\euscr\mathscr \let\mathscr\relax
    \usepackage[scr]{rsfso}
    \begin{document} 
    \title{\textbf{Chapter I: Differentiable Manifolds}}
    \author{}\date{}
    \maketitle
    If $\{A_i\}_{i\in I}\subseteq\euscr{P}(M_1)$, where $\mathcal{P}(M_1)$ refers to the power set of $M_1$, then:
    \[F\bigg(\bigcup_{i\in I}A_i\bigg)=\bigcup_{i\in I}F(A_i)\hspace*{0.7cm}\wedge\hspace*{0.7cm}F\bigg(\bigcap_{i\in I}A_i\bigg)=\bigcap_{i\in I}F(A_i)\]
    \end{document}
  • Welcome to TeX.SE! Please update your code to be a MWE. – TeXnician Feb 6 '17 at 18:26
  • Sorry, but I'm not sure about what you mean by that... My code does compile in my latex version... – Alba Crespo Pérez Feb 6 '17 at 18:29
  • you should never load epsfig at all but why the option in \usepackage[dvips]{epsfig} are you using latex+dvips rather than pdflatex? – David Carlisle Feb 6 '17 at 18:30
  • A MWE is not only compilable, it is the smallest amount of code required to show your problem, so that we can help you without having to dig in tons of lines of code. – TeXnician Feb 6 '17 at 18:31
  • Yes, when I compile I run latex, dvips and ps2pdf. I'm not an expert, just found that this worked at stuck with it. However, I'm really puzzled now because the minimal example I posted does work as I want it to... Maybe it doesn't if I try to use too many alphabets? I'm really confused... – Alba Crespo Pérez Feb 6 '17 at 18:32
4

The commands work correctly, You do not say what you expect.

If I cut your example to a more reasonable size then.

enter image description here

\documentclass[a4paper,12pt]{article}
\usepackage[mathscr]{euscript}
\let\euscr\mathscr \let\mathscr\relax
\usepackage[scr]{rsfso}
\begin{document} 
$P\euscr{P}\mathcal{P}\mathscr{P}$
\end{document}

So all the P work, only you can decide which you want.

| improve this answer | |
  • Yes, your example works, but I don't understand why. I mean, when I compile my entire document, the second and third "Ps" you write look exactly the same, like the third. Do you have any idea why this could be happening? Am I maybe using too many alphabets? However, I'm not getting the "too many alphabets" error... – Alba Crespo Pérez Feb 6 '17 at 18:38
  • Oh, I'm sorry, I made a mistake. I actually was getting the "too many alphabets" error in my bigger code, but missed it, and that's why it wasn't showing the pdf right. Thank you for your answer! – Alba Crespo Pérez Feb 6 '17 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.