3

I need to center the axes in the coordinate origin. However, the axes is not centered and extends down as shown by the red circle.


...

\pgfplotsset{compat=1.11}

...

\begin{document}

\begin{tikzpicture}[scale=1.5]
  \begin{axis} [
    xlabel = \textit{Voltage},
    ylabel = \textit{Current},
    axis lines = middle,
    enlarge y limits = true,
    xmin = 0, xmax = 90,
    ymin = 0, ymax = 150,
    width=15cm, height=8cm,
    grid = major,
    grid style = {dashed, line width=.1pt, draw=gray!30},
    legend pos = north east,
    ]

    \addplot table[x index = {0}, y index = {1}]{\mydata};
    \legend{Townsend}

  \end{axis}
\end{tikzpicture}

\end{document}

enter image description here

1 Answer 1

3

Your problem is simply the option enlarge y limits, which you should set to false instead of true.

1
  • Ty, as has not gave me account u.u
    – LuisPac
    Commented Feb 8, 2017 at 9:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .