3

This is my bib entry:

@online{schiller_einleitung_2016,
author = {Schiller, B.},
title = {{Einleitung für Smart-Home-Einsteiger}},
month = jun,
year = {2016},
url = {URL},
urldate = {2016-09-09}, 
label = {online},
type = {online}}

This is the use package line

\usepackage[style=ieee, urldate =comp, backend=bibtex]{biblatex}

This what I get

B. Schiller. (Juni 2016). Einleitung für Smart-Home-Einsteiger, Adresse: URL (besucht am 09. 09. 2016).

This is what I should get or want.

B. Schiller. (Juni 2016). Einleitung für Smart-Home-Einsteiger, [Online] Adresse: URL (besucht am 09. 09. 2016).

Now the question, why bib(la)tex don't put the term "[Online]" on the output as requested be the IEEE Citation Reference?

Edit1:

deleted the label and types on the bib entry:

@online{schiller_einleitung_2016,
author = {Schiller, B.},
title = {{Einleitung für Smart-Home-Einsteiger}},
month = jun,
year = {2016},
url = {URL},
urldate = {2016-09-09}}

While constructing a new MWE I found that

\documentclass{scrreprt}
\usepackage[style=ieee, urldate =comp, backend=bibtex]{biblatex}
\usepackage[ngerman]{babel}
\bibliography{bib}
\begin{document}
bla \cite{schiller_einleitung_2016}
\printbibliography  
\end{document}

I get again the false Bibliography entry.

However if I comment out the line for german

\documentclass{scrreprt}
\usepackage[style=ieee, urldate =comp, backend=bibtex]{biblatex}
% \usepackage[ngerman]{babel}
\bibliography{bib}
\begin{document}
bla \cite{schiller_einleitung_2016}
\printbibliography  
\end{document}

The result is nice:

B. Schiller. (Jun. 2016). Einleitung fr Smart-Home-Einsteiger, [Online]. Available: URL (visited on Sep. 9, 2016).

4
  • Welcome to TeX.SX! Please post a full MWE.
    – TeXnician
    Commented Feb 8, 2017 at 14:51
  • 3
    I get the expected output with '[Online]' from your entry. So we really need to see an MWE to investigate what's going on. Please check the versions of the biblatex and biblatex-ieee package and report them in your question.
    – moewe
    Commented Feb 8, 2017 at 14:53
  • For all I know you can drop the label = {online}, type = {online} fields, they shouldn't do anything.
    – moewe
    Commented Feb 8, 2017 at 14:57
  • The Versions: BibLaTex 3.6 biblatex-ieeee 1.1q
    – dragon89
    Commented Feb 9, 2017 at 12:11

1 Answer 1

1

You need

\DefineBibliographyStrings{german}{
  andothers   = \mkbibemph{et al\adddot},
  url         = [Online]\adddot\addspace Adresse,
}

that is because in biblatex-ieee the '[Online]' is added via the bibstring url. But ieee.bbx only defines English strings, you will have to do the work for German yourself.

\documentclass[ngerman]{scrartcl}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@online{schiller_einleitung_2016,
author = {Schiller, B.},
title = {{Einleitung für Smart-Home-Einsteiger}},
month = jun,
year = {2016},
url = {http://smarthomewelt.de/intelligentes-wohnen-smart-home-ueberblick/},
urldate = {2016-09-09}, }
\end{filecontents}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[style=ieee, urldate =comp, backend=bibtex]{biblatex}
\addbibresource{\jobname.bib}

\DefineBibliographyStrings{german}{
  andothers   = \mkbibemph{et al\adddot},
  url         = [Online]\adddot\addspace Adresse,
}

\begin{document}
\cite{schiller_einleitung_2016}

\printbibliography
\end{document}

gives

B. Schiller. (Juni 2016). Einleitung für Smart-Home-Einsteiger, [Online]. Adresse: http://smarthomewelt.de/intelligentes-wohnen-smart-home-ueberblick/ (besucht am 9. Sep. 2016).

3
  • Thanks, that is exaktly what i needed. The line "andothers = \mkbibemph{et al\adddot}" is if there is a entry in the bibliography with author= {maier andothers} to make output in maier et al. ?
    – dragon89
    Commented Feb 13, 2017 at 13:12
  • @dragon89 Yes indeed, the andothers bibstring comes into play when a list of authors gets abbreviated either due to and others (note that it's two words) or to the maxnames setting. The default in German is 'u.a.' with this setting (taken from the English settings), you get 'et al.'. If my answer helped you, please consider accepting the answer with the green tick to the left of the answer.
    – moewe
    Commented Feb 13, 2017 at 15:48
  • I am new on stackexchange. Thank you for your explanation how to accept an answer as the correct answer. Done.
    – dragon89
    Commented Feb 15, 2017 at 7:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .