5

I am really new to LaTeX and I need a comprehensive solution for my Thesis

I have this problem since two days and I couldn't find any solution in any other post.

I work with BibDesk on Mac And I used Packages apacite and natbib

@article{Ha89,
Author = {Peter M. Haas},
Date-Added = {2017-02-06 21:15:57 +0000},
Date-Modified = {2017-02-06 21:45:06 +0000},
Journal = {International Organization},
Lastchecked = {03/02/2010 12:54},
Number = {3},
Pages = {377-403},
Publisher = {Peter Haas},
Read = {0},
Title = {Do regimes matter? Epistemic communities and Mediterranean pollution control},
Urldate = { http://www.jstor.org/stable/2706652},
Volume = {43},
Year = {1989}}

this is a stripped version of my document:

\documentclass[11pt, oneside]{article} 
\usepackage{lipsum}
\usepackage[margin=1in, left=1.5in, includefoot]{geometry}  
\usepackage{ragged2e}
% REFERENCE PREAMBLE
%\usepackage{url}
\usepackage{apacite}
\usepackage{natbib}
%\usepackage{biblatex-apa}                                                  
% Bullet preamble
\renewcommand{\labelitemi}{$\bullet$}
\renewcommand{\labelitemii}{$\diamond$}
\renewcommand{\labelitemiii}{$\circ$}
% graphics preamble
\usepackage{graphicx}   %Allows you to import images
\usepackage{float}      %Allows for control of float positions
%HEADER AND FOOTER STUFF
\usepackage{fancyhdr}
 \pagestyle{fancy}
\usepackage{graphicx}       
\usepackage{amssymb}
%Zeilenabstand 1,5 wenn aktiviert 
\usepackage{setspace}\makeatletter\newcommand{\MSonehalfspacing}{\setstretch{1.44}\ifcase \@ptsize \relax\setstretch {1.448}\or\setstretch {1.399}\or\setstretch {1.433}\fi}\newcommand{\MSdoublespacing}{\setstretch {1.92}\ifcase \@ptsize \relax\setstretch {1.936}\or\setstretch {1.866}\or\setstretch{1.902}\fi}\makeatother\MSonehalfspacing %Zeilenabstand Code fertig
\usepackage[hidelinks]{hyperref}   %allows for clickable reference
%                       BEGIN OF DOCUMENT
\citeA{source}
%                       REFERENCES 
\renewcommand{\sectionmark}[1]{\markright{\thesection\ #1}}
\fancyhf{}
\rhead{\fancyplain{}{Identifying the Regime}}
\lhead{\fancyplain{}{List of References}}
\cfoot{\fancyplain{}{\thepage}} 
\setlength\bibitemsep{1.9\itemsep}
\bibliography{/User/Desktop/Thesis/references/mybib.bib}                  
\bibliographystyle{apa}
\addcontentsline{toc}{section {\numberline{}References}                                                       \end{document}

I would like to have the bibliography entry include a retrieved from

enter image description here

I tried to deactivate hyperref – as suggested in another post – but it didn't work. I also tried to activate and deactivate natbib and apacite as well.

I would really appreciate any help...

5

The best current implementation of a true APA style is the biblatex-apa style. Here's a sample document using it. If you want to use the 'Retrieved from' field, you need to name it correctly, the biblatex field name is urldate and the formatting of the date has to be correct too: YYYY-MM-DDTHH:MM:SS (if you need exact times, although they won't be printed in the output) or YYYY-MM-DD if you just need the day. (I also added some braces in your title so that the capitalization is correct.)

This needs to be compiled using biber (not bibtex). This should be configurable in your editor. See the following question for ways to do this automatically:

\documentclass{article}
% this is a way of including a bib entry into a document for testing
\begin{filecontents}{\jobname.bib} 
@article{Ha89,
Author = {Peter M. Haas},
Date-Added = {2017-02-06 21:15:57 +0000},
Date-Modified = {2017-02-06 21:45:06 +0000},
Journal = {International Organization},
urldate = {2010-02-03T12:54:00},
Number = {3},
Pages = {377-403},
Publisher = {Peter Haas},
Read = {0},
Title = {Do regimes matter? {Epistemic} communities and {Mediterranean} pollution control},
url = {http://www.jstor.org/stable/2706652},
Volume = {43},
Year = {1989}}
\end{filecontents}
\usepackage[american]{babel}
\usepackage[style=apa]{biblatex}
\defbibheading{bibliography}[\bibname]{\section{#1}}
\addbibresource{\jobname.bib} % replace this with your actual bibfile name
\usepackage{csquotes}
%\usepackage{hyperref} load this (last) if you want live links
\begin{document}
This is an in text citation: \textcite{Ha89}.  This is a parenthetical one: \parencite{Ha89}.
\printbibliography
\end{document}

output of code

  • Wow Thank you very much Alan. So I have to change the editor configuration from biblatex to biber? How do I do that? I downloaded Biber and I tried your coding but it didn't work and I got an error "Option clash for package biblatex" I'm sorry, I really am a raw recruit. – T.F.L. Feb 9 '17 at 0:24
  • You're using a Mac. What editor are you using? You shouldn't have had to download anything if you have a current MacTeX installed. And you should remove all other bibliography related code from your preamble and document. (I'm assuming the error you get isn't from this document.) – Alan Munn Feb 9 '17 at 0:46
  • Do you have a reference for, or some other means to support, the view that "The best current implementation of a true APA style is the biblatex-apa style"? I suspect it might be news to Erik Meijer, the maintainer of the apacite package, that his package doesn't do a good job of implementing the 6th edition of the APA's bibliography formatting guidelines. – Mico Feb 9 '17 at 1:25
  • 2
    @Mico Maybe that's a bit strong, but biblatex-apa "typesets just about every useful example from (APA 6.11)–(APA 6.21) and (APA 7.01)–(APA 7.11)." so it conforms with APA 7. I don't know if this is a substantive change from APA 6 or not, and I'm not trying to impugn the apacite package. – Alan Munn Feb 9 '17 at 1:33
  • Thanks for this pointer. (I must confess to not knowing if there are any meaningful differences, at least as bibliography formatting goes, between versions 6 and 7 of "The Manual".) – Mico Feb 9 '17 at 1:41
4

Three suggestions:

  • Don't load both the apacite and the natbib packages; instead, run either

    \usepackage{apacite}
    

    or

    \usepackage[natbibapa]{apacite}
    

    (Use the latter if you wish to use the natbib-like citation commands, e.g., \citet and \citep).

  • Do familiarize yourself with the user guide of the apacite package. In particular, the user guide provides lots more information about all options (including natbibapa) that the package recognizes.

  • Don't use the bibliography style named apa -- it dates back to 1992. Really! Instead, run

    \bibliographystyle{apacite}
    

    for a bibliography style that implements version 6.03 of the APA guide.

Incidentally, your sample bib entry -- which I assume you downloaded from some Internet repository -- contains two serious errors: The field named Urldate should be named Url (after all, the contents of field are a URL string, not a date...), and the field currently named Lastchecked should be named Urldate. Moral of the story: Don't place unfounded trust and confidence in material obtained "from the Internet". By all means, verify. I've made two further adjustments in the bib entry: In the title field, I've placed curly braces around the words "Epistemic" and "Mediterranean, so that they won't be typeset as "epistemic" and "mediterranean", and I've changed - to -- in the pages field, to instruct LaTeX to create a proper en-dash.


enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@article{Ha89,
Author     = {Peter M. Haas},
Date-Added = {2017-02-06 21:15:57 +0000},
Date-Modified = {2017-02-06 21:45:06 +0000},
Journal    = {International Organization},
Urldate    = {03/02/2010 12:54},
Number     = {3},
Pages      = {377--403},
Publisher  = {Peter Haas},
Read       = {0},
Title      = {Do regimes matter? {Epistemic} communities and {Mediterranean} pollution control},
Url        = {http://www.jstor.org/stable/2706652},
Volume     = {43},
Year       = {1989}
}
\end{filecontents}

\documentclass{article}
\bibliographystyle{apacite}
\usepackage[natbibapa]{apacite}
\usepackage[hyphens,spaces]{url}
\usepackage[colorlinks,allcolors=blue]{hyperref}

\begin{document}
\cite{Ha89}
\bibliography{mybib}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.