1

I am writing a thesis on theoretical particle physics and need some particle names. I stumbled upon hepnames which in turn uses hepparticles. After I changed my whole document, I realized that the placement of superscript is messed up by this package. That is even in normal math, not only when you use its commands.

Without hepparticles:

\documentclass{article}
\usepackage{hepparticles}
\begin{document}
\( q^j \quad e^\ell \quad m_{q^j} \quad m_{e^\ell} \)
\end{document}

without hepparticles

With hepparticles

\documentclass{article}
\usepackage{hepparticles}
\begin{document}
\( q^j \quad e^\ell \quad m_{q^j} \quad m_{e^\ell} \)
\end{document}

with hepparticles

Apart from that I really like the package and would not like having to revert all my changes (I'd probably redefine the ones I used myself, but I don't know how to do it in a math and non-math safe way, as the package does). Is there any known fix? Should I contact the package creator and file a bug?

(I would like to tag this question as hepparticles, but it doesn't exist and I don't have the rep…)

  • Please, don't use the minimal class for example; it has never been meant for this. – egreg Feb 9 '17 at 15:38
  • The package loads subdepth, which is responsible for this appalling output. – egreg Feb 9 '17 at 15:42
  • @egreg thanks for the info, I changed it. Doesn't change the behavior, though. – Philipp Stephan Feb 9 '17 at 15:47
2

The behavior is due to the package subdepth which tries to fix something and breaks several others. ;-)

You return to normal by loading subdepth with the low-sup option.

\documentclass{article}
\usepackage[low-sup]{subdepth}
\usepackage{hepparticles}
\begin{document}
\( q^j \quad e^\ell \quad m_{q^j} \quad m_{e^\ell} \)
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.