1

Before update TL was working fine. After update got the error:

Package l3sort Error: This package is obsolete --- use 'expl3' instead. use 'expl3' instead}\@ehc

l3* packages were updated.

How to get back to older l3 packages? or how to tell TL people about it?

I use these packages:

 \documentclass[ebook,openany]{memoir}

 \settypeblocksize{43pc}{27pc}{*}%{38pc}{27pc}{*}%{43pc}{27pc}

 \setlrmargins{0.75in}{*}{*} \setulmargins{6pc}{*}{*}%{6pc}

 \setheadfoot{13pt}{2.5pc}%{13pt}{2.5pc} \setheaderspaces{*}{2.5pc}{*}

 \checkandfixthelayout 

 \fixpdflayout 

 \usepackage[osf,sc]{mathpazo}  %
  %[sc] real small caps, family pplx; [osf] small caps, oldstyle digits
 in text, family pplj 

\usepackage[euler-digits]{eulervm} % Euler math

 \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc}

 \usepackage{amsmath} \usepackage{amsfonts} \usepackage{amssymb}

 \usepackage{csquotes} \usepackage[font=normalsize]{idxlayout} 

 \usepackage{tikz} \usetikzlibrary{matrix}  \usetikzlibrary{cd}

 \usetikzlibrary{shapes,backgrounds}  \usepackage{graphicx}

 \usepackage{theorem} \usepackage{float}

 \usepackage[sort=use,toc,style=long3col]{glossaries}

 \usepackage[greek,spanish,es-lcroman]{babel} \usepackage{wasysym}

 %emoticons :) 
\usepackage[hang]{footmisc}


\usepackage[hidelinks,colorlinks = true,linkcolor = black,urlcolor  =
 blue,citecolor = blue,anchorcolor = blue]{hyperref}


\usepackage{exsheets} \usepackage{calc}

closed as off-topic by clemens, Maarten Dhondt, Schweinebacke, Werner, Zarko Feb 9 '17 at 18:01

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    As a workaround until a better solution comes up you can add \expandafter\def\csname ver@l3sort.sty\endcsname{} at the begin of your document. This will prevent that l3sort is loaded. You will perhaps have to load expl3 instead. – Ulrike Fischer Feb 9 '17 at 16:40
  • 2
    exsheets loads l3sort. You should notify the author. Using my code above before should solve the problem. – Ulrike Fischer Feb 9 '17 at 16:49
  • 2
    Well sure the update changed things. This can happen. When exsheets has been updated too the error will disappear. – Ulrike Fischer Feb 9 '17 at 17:07
  • 2
    I have sent the updated version to CTAN a few hours ago. This should be fixed soon… – clemens Feb 9 '17 at 17:14
  • 5
    I'm voting to close this question as off-topic because the issue is a temporary package dependency hickup. – clemens Feb 9 '17 at 17:17