1

I am using a custom R Markdown Latex Template, and BibTex, but I am having trouble getting the bibliography to work.

With the default pandoc-citeproc I get the error:

pandoc-citeproc: Error parsing references: expected [a], encountered Object

Which occurs before the .tex file is generated, not during the compilation of the .tex file. I've tried uninstalling and reinstalling pandoc, which doesn't help.

When I add --biblatex as a pandoc argument I get a new error that occurs after the .tex file is generated:

! Undefined control sequence.
l.41 We are writing this using LaTeX \autocite

If I replace \autocite with \cite in the .tex file it compiles nicely. It would be nice if I could get pandoc/biblatex to use \cite instead of \autocite so I don't have to manually intervene. Am I misunderstanding something?

closed as unclear what you're asking by moewe, clemens, Zarko, TeXnician, Torbjørn T. Apr 12 '17 at 9:35

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Seems like you should use the option --natbib then, as suggested here tex.stackexchange.com/a/279739/95109 – Christoph S Feb 9 '17 at 21:02
  • 2
    See also github.com/jgm/pandoc/issues/2392. But it is weird that \autocite would be undefined when you load biblatex. Can you show us a minimal example of a generated .tex file (with the call to biblatex and all the options)? – moewe Feb 10 '17 at 6:39
  • Any news here? Were you able to get things working in the end? Seeing that the question is about pandoc and lacks an MWE as well as the produced .tex file, there is not much we can do. I will probably vote to close this question if nothing more happens in due time. – moewe Mar 25 '17 at 16:32