20

I am trying to use a CV template I got online. I really like it, but I am a bit of a noob and don't know how to resolve the errors when I compile. I get this error first, I am not sure if there may be any more:

unicode-math.sty 385 ! keyvalue error: "option-unknown" ! ! Unknown option 'vargreek-shape' for package unicode-math. ! ! See the keyvalue documentation for further information. ! ! For immediate help type H . !...............................................
l.385 \ProcessKeysOptions {unicode-math}

I have tried to look at resolutions online for similar problems, none of which helped very much. Is there a way I can modify it to make it compile?

This is the main code:

\documentclass[11pt, a4paper]{awesome-cv} 
\fontdir[fonts/] % Specify the location of the included fonts
\colorlet{awesome}{awesome-red}
\renewcommand{\acvHeaderSocialSep}{\quad\textbar\quad} 
\name{Claud D.}{Park}
\address{246-1002, Gwangmyeongmayrouge Apt. 86, Cheongna lime-ro, Seo-gu, Incheon-si, 404-180, Rep. of KOREA}
\mobile{(+82) 10-9030-1843}
\email{posquit0.bj@gmail.com}
\homepage{www.posquit0.com}
\github{posquit0}
\linkedin{posquit0}
\position{Software Engineer{\enskip\cdotp\enskip}Security Expert}
\quote{``Make the change that you want to see in the world."}
\makecvfooter{\today}{Claud D. Park~~~•~~~Résumé}{\thepage}
\begin{document}
\makecvheader 
\input{cv-sections/education.tex}
\input{cv-sections/skills.tex}
\input{cv-sections/experience.tex}
\end{document}

Sorry, i don't even know where to begin to look and what parts you'd like me to show to you.

  • Welcome to TeX.SE. Please always provide a small working example (MWE). It helps us to help you. In your case, you seem to load a package by \usepackage[vargreek-shape]{somepackage} which seems not to be defined. Maybe a simple typo, maybe something else. Hard to say without the complete example. – Jan Feb 10 '17 at 12:15
  • The template is outdated and should be corrected. The option has been removed from a current unicode-math: tex.stackexchange.com/questions/351955/… – Ulrike Fischer Feb 10 '17 at 12:26
  • I realize it is outdated from previous answers, but is there a way to modify it so that I can still use it? – Anna Feb 10 '17 at 12:34
  • 1
    The code has already been corrected: github.com/posquit0/Awesome-CV/commit/…. So simply get the newest version. – Ulrike Fischer Feb 10 '17 at 13:00
  • I have downloaded the most updated version of the template and while I can edit it online on overleaf, I can't compile without this error ! LaTeX Error: \usepackage before \documentclass. I understand that \usepackage should come after \documentclass but in the newest version the creator uses \Providesclass. I would like to know where the problem lies and why it can still work on Overleaf and not on TeXworks when compiled with Xelatex. – Anna Feb 11 '17 at 21:01
27

There is a new version of the template.

Check here: https://github.com/posquit0/Awesome-CV/commit/6e8586270b203d5861377ba017f30cf16ed425cc

You have to replace line 1) with line 2) and you will get it fixed:

1) \RequirePackage[math-style=TeX,vargreek-shape=unicode]{unicode-math}

2) \RequirePackage{unicode-math}

4

I managed to fix this issue by commenting out the below line in coverletter.cls and awesome-cv.cls

% comment out this line which causes this issue
%\RequirePackage[math-style=TeX,vargreek-shape=unicode]{unicode-math}

And add a new statement

% add this instead
\RequirePackage{unicode-math}

As Consuelo mentioned, the corresponding fix can be found in this git commit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.