7

I have tried to install XeTeX on my Debian system, but this does not appear to work. Here are the steps I took:

  • I loaded TeX Live 2011 with tlmgr -gui.
  • I loaded a repository.
  • I selected "not installed packages".
  • I selected "collection-xetex".
  • I clicked "install".
  • The log reported the installation of the included packages, including xetex.
  • Then a warning appeared saying "Running install collection-xetex failed. Please consult the log window for details."

The log reports the following:

/usr/local/bin/fmtutil: 1: xetex: not found Error: `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini' failed

#

fmtutil: Error! Not all formats have been built successfully. Visit the log files in directory /usr/local/texlive/2011/texmf-var/web2c for details.

#

This is a summary of all failed' messages: xetex -ini -jobname=xetex -progname=xetex -etex xetex.ini' failed `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini' failed

tlmgr: exiting unsuccessfully (status 1).

Some additional details:

  • I was unable to find a xelatex command anywhere in the path.
  • Rebooting the computer resulted in no known change.
  • Uninstalling and reinstalling from a different repository produced identical results.
  • The TeX Live Manager 2011 GUI currently reports that "collection-xetex" is installed.

What do I need to do to get XeTeX working?

4
  • 2
    It seems that you don't have correctly set the PATH. Did you choose to make symlinks for the executables?
    – egreg
    Nov 19, 2011 at 0:39
  • During the first install, I set TeX Live to make symlinks. All of the packages from the first install are available. I see now that xelatex is inside my TeX Live directories, but there is no symlink. Is there a setting somewhere that has TeX Live fix symblinks?
    – Village
    Nov 19, 2011 at 1:05
  • I discovered the "Update Symbolic Links" option in "Actions" > "Handle symlinks in system dirs". It installed fine now.
    – Village
    Nov 19, 2011 at 1:29
  • 1
    @Village: Staying true to this Q&A, I suggest you write up a separate answer to your original question, keeping in mind that it may be helpful to future readers experiencing a similar problem to yours. Self-answers (even if they are accepted) are perfectly admissible, and a well-written answer may earn you additional reputation.
    – Werner
    Nov 19, 2011 at 3:55

2 Answers 2

9

The problem lies in the fact that you chose to create symbolic links for the executables in /usr/local/texlive/2011/bin/<architecture> to /usr/local/bin.

With tlmgr there's the possibility to update them, but the action is not performed automatically.

However, my advices are:

  1. Always install the full TeX Live

  2. Never create symbolic links, particularly on Debian based systems

If you don't have strict space constraints, do a full TeX Live install. It would have avoided the problem of installing the XeTeX subsystem.

Changing what's in /usr/local/bin is dangerous as other system utilities may choose to install something there. It's better to change the PATH variable and the safest method is to write a file zzz-texlive.sh containing

export PATH=/usr/local/texlive/2011/bin/`uname -i`-linux:$PATH
export MANPATH=/usr/local/texlive/2011/texmf/doc/man:$MANPATH
export INFOPATH=/usr/local/texlive/2011/texmf/doc/info:$INFOPATH
unset TEXINPUTS
unset TEXMFCONFIG

and move it into /etc/profile.d. After a logout/login cycle, the PATH variable will contain the correct directory for the executables.

3
  • 3
    This is not the proper way of setting the system-wide $PATH on Debian systems. Particularly because root needs to have the directory in $PATH and root shells don't read /etc/profile (IIRC). Instead, it should be added to /etc/environment. Note that this file is not a shell script but just a list in the form VARIABLE=<stuff>. You can also add MANPATH=<stuff> and INFOPATH=<stuff> here such that man and info will find the documentation from your TeX Live installation.
    – kahen
    Nov 19, 2011 at 13:14
  • It doesn't help that the documentation on how to install Vanilla TeX Live 2011 on Debian systems (link) is a bit inaccurate since its sample texlive-local file doesn't list texlive-base-bin. Caught me off guard when I installed it manually myself. Now if only I could get sudo to work with the TeX Live binaries... "sudo: mkluatexfontdb: command not found" (but it's in all users' $PATH... Weird)
    – kahen
    Nov 19, 2011 at 13:21
  • FWIW, I figured out the problem with sudo. It's usually compiled with a built-in "secure path" to prevent accidental or malicious clobbering of programs that are normally executed with sudo. Contrast sudo -i followed by echo $PATH with sudo env | grep PATH.
    – kahen
    Nov 19, 2011 at 16:35
0

As stated Egred is always better to install the full updated TeX Live. Some times the repositoires are not updated. I have fixed the same issue using this ppa.

sudo add-apt-repository ppa:jonathonf/texlive
sudo apt update && sudo apt install texlive-full

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .