8

I am using natbib and agsm for harvard-style referencing. My related code is

\usepackage{natbib}
\bibliographystyle{agsm}

Then I am using \citep{} for citations. My problem is that in text I am getting

(Author et al. 2012)

but and I want

(Author et al. 2012)

Does anyone know how to change this and get 'et al' in italics in the text?

I am using TexPad and BibDesk and I have not been able to find the .bst files in Terminal.

I know that it is often correct to have the 'et al.' unitalicised but my university regulations requires italics.

  • 2
    Welcome to TeX.SX! Please add the code of a complete document (starting with \documentclass and ending with \end{document}) to your post that illustrates the problem. Just use the edit button. – gernot says Reinstate Monica Feb 14 '17 at 17:37
  • 1
    Copy the agsm file to something else and edit the copy. – JPi Feb 14 '17 at 18:00
  • Hi, I used named instead of agsm and this provided a simple answer for me. Thank you for your help! – TCS Feb 14 '17 at 22:17
  • To locate the fileagsm.bst, type kpsewhich agsm.bst at a command prompt in a terminal window. – Mico Feb 14 '17 at 22:50
7

I suggest you proceed as follows:

  • Find the file agsm.bst in your TeX distribution. Make a copy of the file and call the copy, say, agsmemph.bst. (Don't edit an original file of your TeX distribution directly.)

  • Open the file agsmemph.bst in your favorite text editor -- the one you use to edit your tex files will do fine.

  • Do a global search and replacement of et~al. with \emph{et~al.}. There should be five such instances.

  • Save the file agsmemph.bst either in the directory where your main tex file is located or in a directory that's searched by BibTeX. If you choose the latter option, be sure to also update the filename database of your TeX distribution appropriately.

  • In your main tex file, change the argument of \bibliographystyle from agsm to agsmemph and perform a full recompile cycle -- LaTeX, BibTeX, LaTeX, LaTeX -- to fully propagate all changes.

Happy BibTeXing!

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@misc{abcd,
  author = "Anne Author and Bertha Buthor and Carla Cuthor and Doris Duthor",
  title  = "Thoughts",
  year   = 3001,
}
\end{filecontents}

\documentclass{article}
\usepackage{natbib}
\bibliographystyle{agsmemph} %  <-- 'agsmemph' is being used

\begin{document}
\citet{abcd}
\bibliography{mybib}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.