1

There are several examples for making bibliographies not start each entry with new lines (e.g., Removing Line Breaks in Bibliography compiled with Biblatex and Removing Line Breaks in Bibliography compiled with Biblatex). Generally (as in my case) this is because of page limits in grant applications.

However, all the ones I've found use a numbered citation system, while I want to use natbib and have the author's name appear. I can't seem to make these work with natbib.

This example (from Removing Line Breaks in Bibliography compiled with Biblatex) works if the natbib command is commented out.

\documentclass{article}
%\usepackage{natbib}
\usepackage[firstinits=true,backend=bibtex,doi=false,isbn=false,url=false]{biblatex}
\AtEveryBibitem{%
  \clearfield{pages}%
}
\renewcommand{\bibfont}{\normalfont\footnotesize}
\addbibresource{biblatex-examples.bib}

\defbibenvironment{bibliography}
  {\noindent}
  {\unspace}
  {\printtext[labelnumberwidth]{%
    \printfield{prefixnumber}%
    \printfield{labelnumber}}
    \addspace}
\renewbibmacro*{finentry}{\finentry\addspace}

\begin{document}
  \cite{wilde,shore,springer}

  \printbibliography[heading=none]
\end{document}

Is there a way to make it work with natbib?

  • I eventually didn't need the space, so ultimately I did not need this. – Joel Jul 29 '17 at 3:01
2

Tell biblatex with option natbib to use natbib.

With the following MWE

\documentclass{article}

%\usepackage{natbib} % <================================================

\usepackage[%
  giveninits=true,
  backend=bibtex,
  doi=false,
  isbn=false,
  url=false,
  natbib,     % <=======================================================
]{biblatex}
\AtEveryBibitem{%
  \clearfield{pages}%
}
\renewcommand{\bibfont}{\normalfont\footnotesize}
\addbibresource{biblatex-examples.bib}

\defbibenvironment{bibliography}
  {\noindent}
  {\unspace}
  {\printtext[labelnumberwidth]{%
    \printfield{labelprefix}%
    \printfield{labelnumber}}
    \addspace}
\renewbibmacro*{finentry}{\finentry\addspace}


\begin{document}
  text \cite{wilde,shore,springer} text

  \printbibliography[heading=none]
\end{document}

I get only one warning (okay) and the resulting pdf:

resulting pdf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.