1

I've been trying to get vim and Okular to talk to each other with forward and reverse search.

I have

vim --servername GVIM --remote-silent +%1 %f

in my Okular editor configuration. When I run vim with vim --servername GVIM shift-clicking in Okular causes the following error to appear in vim:

E492: Not an editor command: %1|cal foreground()|if &im|star|en|redr|f

Random error text sometimes also appears in the LaTeX document I'm trying to edit, but this hasn't been happening lately. I also have in my ~/.vim/ftplugin/tex.vim

let g:Tex_CompileRule_dvi = 'latex -src-specials -interaction=nonstopmode $*'

Does anyone have any ideas how to get this working?

1 Answer 1

0

You have a typo, change number 1 for the letter l:

gvim --servername GVIM --remote-silent +%l %f

2
  • Wow, thanks! This isn't the first time in recent history I've mistaken ls for 1s, you'd think I'd have learned by now. Apr 9, 2017 at 8:49
  • It happens, they are terribly similar :) Please accept the answer to mark the question as solved.
    – phcerdan
    Apr 9, 2017 at 23:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .