3

I'm trying to use the siunitx package to display binary units. I have loaded the package using \usepackage[detect-weight=true, load-configurations=binary]{siunitx}but when I try to type \SI{4}{\gibi \byte} I get this error: siunitx error: "prefix-only" Prefix with no unit. ...giga \hertz} así como \SI{4}{\giga \byte}.

I've read that the package version matters when using binary units, mine is siunitx 2017/02/01 v2.7c

How can I solve my problem?

Thanks

5

You have to use the package option binary-units=true (or just binary-units), as specified in the documentation:

Binary data is expressed in units of bits and bytes. These are normally given prefixes which use powers of two, rather than the powers of ten used by the SI prefixes. As these binary prefixes are closely related to the SI prefixes, they are defined by siunitx but do have to be loaded using binary-units = true (or simply binary-units) The units \bit and \byte are then also available.

The option load-configurations is deprecated in favor of the abbrevations, binary-units and version-1-compatibility options.

This compiles for siunitx v2.7c from 2017/02/01

\documentclass{article}

\usepackage[binary-units=true]{siunitx}

\begin{document}
\SI{4}{\gibi\byte}
\end{document}

enter image description here

  • @jagjordi: You're welcome. Happy TeXing! – user31729 Feb 20 '17 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.