0

After downloading the newest version of TexStudio (2.12.2) I've got the following problem. When I work with multiple tex-files in the editor and try to compile and build my current file (my settings for the root document: detect automatically), I don't always get the right file.

For some reason, in order to get the right file to be compiled, I need first to save this tex-file explicitly (so not the automatic saving by compiling the file), and then compile and build it.

Did I accidentally change some settings or is this some kind of bug?

  • Which operating system do you use? – user36296 Feb 20 '17 at 23:48
  • And if you declate it as root document? – Bernard Feb 21 '17 at 0:27
  • I use MacOS; if I set it as root document it works but this is annoying since I need to switch between tex-files – AYK Feb 21 '17 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.