2

I am typesetting a tufte-book document with XeLaTeX that has both English and Arabic text. The Tufte-style title pages consistently break, whether I use the package arabxetext or polyglossia. I suspect a clash with the underlying bidi package.

Here is a minimal example with arabxetex:

\documentclass[nols,justified]{tufte-book}
\usepackage{lipsum}
\usepackage{arabxetex}
\title{Some Book}
\author[Series]{\textit{ John Doe}}
\publisher{World Publisher}
\begin{document}
\maketitle
\section{Foo Bar}
\begin{arab}
بعد هامش وإقامة المتحدة و، أم السادس وبالرغم فقد.
\end{arab}
\lipsum[1-2]
\end{document} 

Here is the minimal example with polyglossia:

\documentclass[nols,justified]{tufte-book}
\usepackage{lipsum}
\usepackage{polyglossia}
\usepackage{fontspec,xltxtra,xunicode}
\setdefaultlanguage{english}
\setotherlanguage{arabic}
\newfontfamily\arabicfont[Script=Arabic,Scale=1.5] {Amiri Quran}
\title{Some Book}
\author[Series]{\textit{ John Doe}}
\publisher{World Publisher}
\begin{document}
\maketitle
\newpage
\section{New Section}
\begin{Arabic}
بعد هامش وإقامة المتحدة و، أم السادس وبالرغم فقد.     
\end{Arabic}  

\lipsum[1-2]
\end{document} 

Both give the following errors:

LaTeX Error: Command \XeTeX already defined.
XeLaTeX Error: Command \XeTeX already defined.

Is there a solution for using mixed English/Arabic text with the tufte-book document class? I have tried the biditufte class, but find that is designed for RTL text.

The title page compiles incorrectly. The following example demonstrates what the title page should look like:

\documentclass[nols,justified]{tufte-book}
\usepackage{lipsum}
\title{Some Book}
\author[Series]{\textit{John Doe}}
\publisher{World Publisher}
\begin{document}
\maketitle
\section{Foo Bar}
\lipsum
\end{document} 

enter image description here

  • It's easy: see below! – JPi Feb 21 '17 at 20:57
1

enter image description here

Haha!

% !TeX program = xelatex
\documentclass[nols,justified]{biditufte-book}
\usepackage{lipsum}
\usepackage{polyglossia}
\usepackage{fontspec,xltxtra,xunicode}
\setdefaultlanguage{english}
\setotherlanguage{arabic}
\newfontfamily\arabicfont[Script=Arabic,Scale=1.5] {Amiri Quran}
\title{Some Book}
\author[Series]{\textit{ John Doe}}
\publisher{World Publisher}
\begin{document}
\maketitle
\newpage
\section{New Section}
\begin{Arabic}
بعد هامش وإقامة المتحدة و، أم السادس وبالرغم فقد.     
\end{Arabic}  

\lipsum[1-2]
\end{document} 
  • Do you get an error message: LaTeX Error: Command \XeTeX already defined. and XeLaTeX Error: Command \XeTeX already defined.` – JohnW Feb 22 '17 at 4:10
  • As well, the title and pages are all shifted toward the margin. I have compiled with biditufte on overleaf.com with the same result, so I don't believe the problem is my configuration. Do you have the same result? – JohnW Feb 22 '17 at 4:33
  • No, I don't. Everything looks fine to me. – JPi Feb 22 '17 at 13:27
0

\documentclass[nols,justified]{biditufte-book} does solve the problem, however the option [LTRgeometry] is needed if the document is primarily written in a left-to-right language like English. The [justified] option is also unnecessary with the biditufte-book class. Partial documentation for the biditufte-book document class book is found in the bidi documentation.

  • Good comment.... – JPi Feb 25 '17 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.