1

I need an index with the first delimiter blank (instead of ,) and no en-dash for a range of pages. I know how to do it manually in the ind.file, but of course I would like to do it automatically with a ist (or mst) file. I use imakeidx. There is no effect and I obtain the message " blabla ist file not found", although I put it in the same folder as my main text.

MWE :

\documentclass[11pt,a5paper]{article}
 \usepackage{imakeidx}
 \makeindex[options=-s blabla]

 \begin{document} 
A fox jumps\index{fox} over a gate\index{house}.  
It disappears in the wood\index{wood}.  
\printindex
\end{document}

blabla.ist file

delim_0 "\\quad"
delim_r  "-"

I obtained for the Index fox, 1 wood, 1 house, 1

instead of fox 1 wood 1 house 1

Perhaps my .ist file is not correct : I typed it in LaTeX and saved it as Document (and type the correct name at the finder level), but it appears still with a TeX icon (and the type is TeX text file). I also tried texedit with no more success.

  • With blabla.ist in the same folder I get Scanning style file ./blabla.ist..done (2 attributes redefined, 0 ignored). – egreg Feb 21 '17 at 23:55
  • Happy you ! I get : Index style file blabla not found. Usage: makeindex [-ilqrcgLT] [-s sty] [-o ind] [-t log] [-p num] [idx0 idx1 ...]. How did you create the .ist file concretely : you copy my lines in a LaTeX document, then rename it ? What is the document type indicated ? Do you get the index without the commas as first delimiter ? I do not understand what is not working. – Catherine Feb 22 '17 at 8:14
  • I tried your MWE and it works fine for me. One thing to check: do you have file extensions hidden on your OS? Maybe the file was actually saved as blabla.ist.tex but your OS is hiding the .tex part. – Nicola Talbot Feb 22 '17 at 8:41
  • @Nicola :you are right, thanks a lot ! I put the details underneath as an answer as it may help others. Thanks for leading me in the right direction ! – Catherine Feb 22 '17 at 12:38
1

As pointed out by Nicola, the problem came from the fact that the file extension type was not correct. It may be not sufficient to change the extension name at the Finder level as said elsewhere. I had to go to the infobox of the supposed .ist file (which was in fact not a real .ist), open the "name and extension" section in the infobox, change HERE the extension in order to have only .ist. A message asks if it is ok to change the extension and one answers yes. And indeed it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.