2

I am writing my thesis using TeXstudio. I have a .tex file with my writings and a .bib file with my references, where I have so far copy pasted references from Google Scholar to the .bib file, and fed those into the .tex document (and of course those reference appear then at the end of the document). All my references have the format:

@article{keyword,
  title={Title},
  author={Surname, Name and Surname, Name},
  journal={Journal},
  volume={Number},
  number={Number},
  pages={Pages},
  year={Year},
  publisher={Publisher}
} 

So far I haven't had any trouble when I use the command \cite or \citep in my .tex document, but with ONE particular author (and please let me know if this isn't appropiate to do):

@article{altmann2004b,
  title={Language-mediated eye movements in the absence of a visual world: The ‘blank screen paradigm’},
  author={Altmann, Gerry TM},
  journal={Cognition},
  volume={93},
  number={2},
  pages={B79--B87},
  year={2004},
  publisher={Elsevier}
}

Whenever I use \cite{altmann2004b} or \citep{altmann2004b}, instead of the surname only, there is always G. Altmann (2004) in the text. I repeat, this only happens with THIS author (or surname).

What could it be? May it be related to the surname itself (that it may be in conflict with some command or function)? May it be some sort of bug?

EDIT:

Sorry, I was trying to narrow down the problem. My document starts with something like this:

\documentclass[paper=a4, fontsize =12pt, pagesize=pdftex, parskip=half]{scrreprt}
\renewcommand{\baselinestretch}{1.5} 

\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}



\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[main=english, ngerman]{babel}
\usepackage[babel, english]{csquotes}
\usepackage{verbatim}
\usepackage{graphicx}
\usepackage{float}

\usepackage[natbibapa]{apacite}

\begin{document}


\chapter{Introduction}
\setcounter{page}{0}
\pagenumbering{arabic}


\cite{altmann2004b}


\bibliography{references.bib}
\bibliographystyle{apacite}


\end{document}

Now I realized that when I run this single reference, everything is fine. However, as soon as I cite another reference (as the one below) and add another line with \citep{ altmann1999b} from the same author, the problem begins:

@article{altmann1999b,
    title={Incremental interpretation at verbs: Restricting the domain of subsequent reference},
    author={Altmann, Gerry TM and Kamide, Yuki},
    journal={Cognition},
    volume={73},
    number={3},
    pages={247--264},
    year={1999b},
    publisher={Elsevier}
}

I hope this is clearer now.

  • Can you please provide us with a Minimal Working Example? This questions shows us nothing about biliography packages you are using. Thus, it is hard to help you without simply guessing. – HATEthePLOT Feb 25 '17 at 15:23
  • Welcome to TeX.SX! Please show us the complete code, from \documentclass up to \end{document}, after removing unrelated stuff. From the information that you provided so far I cannot reproduce your problem. – gernot Feb 25 '17 at 15:30
  • Sorry, I updated my question above. Feel free to remove whatever is unnecessary and please let me know if I am still missing something. – Alba Conb Feb 25 '17 at 16:35
  • Better to use setspace than setting \baselinestretch like that. See KOMA's documentation. You don't need \setcounter{page}{0}. – cfr Feb 25 '17 at 16:42
  • Do you have any warnings or errors. At the moment your reported behaviour can't be reproduced. – Marco Daniel Feb 25 '17 at 19:07
1

The addition of the initial is to ensure that each author list is unique i.e. that Author 1 and Author 2 is not confused or conflated with Author 1. This is the intended behaviour and not a problem to be solved.

  • Thank you for the response. Apparently, I mistakenly had one reference without the compound name (Gerry instead of Gerry TM) so yes, it took it as two authors instead of one. Now it works. Sorry for the inconvenience!! :S – Alba Conb Feb 25 '17 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.