2

I am using TeXstudio as an editor. When errors occur, TeXstudio does not compile the pdf at all. I know of other editors, that there is a way of ignoring the errors and still compile the pdf. Of course, it might look different than intended, because of the errors, but at least you get a pdf and know what the error actually does to your pdf.

So, I couldn't find out how to do this in TeXstudio, does anyone know?

  • 1
    Go to Options>Configure>Commands and use the option: -interaction=nonstopmode %.tex on pdflatex command line, for example. – Sigur Feb 27 '17 at 22:21
  • 2
    However you should try to fix the error even if you get a PDF result ;-) You wouldn’t drive a car with four flat wheels even if it’s moving, would you? – Tobi Feb 27 '17 at 22:29
  • @Sigur Do you want to add an answer? Please don't forget that errors should be fixed immediately. – Johannes_B Apr 9 '17 at 11:53
  • thx a lot guys, I have found the hidden Folder and stored them in the same file now. It seems to be working. I mean I am trying to run a .tex file, which I know is working on another PC, and it Returns an error, but this has probably to do with something else and I post another question about it. – user123551 Apr 9 '17 at 11:57
  • @Johannes_B, sorry. I'm quite busy now. Please, feel free to answer if you wish. Regards. – Sigur Apr 10 '17 at 13:23
3

Just to expand on the answers in the comments, you can add the option

-interaction=nonstopmode %.tex

into the command for the relevant engine that you're using. You can find this option in TeXstudio under:

Options -> Configure TeXstudio.. -> Commands

non-stop

  • In my case the nonstopmode option in TexStuiod does not work. It seems to be an issue with TexStudio. The same compiling command (copied and pasted from TexStudio's Messages window) run in terminal works fine [pdflatex -interaction=nonstopmode -synctex=1 --shell-escape <name>.tex] – Gianni Lombardo Jan 15 at 13:34
  • 1
    @GianniLombardo Since your issue is in effect different to this what should be accepted answer. I suggest you search other answers to "TeXstudio" questions If you cant fix the internal settings then raise a fresh question explaining that you can run TeX from command line but not get the same response from an internal call. however as it is an editor problem (not your tex) I suggest TeXstudio support site would be potentially best for this issue – user170109 Jan 15 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy