3

I would like to get latex code for two commutative diagrams joined by a function between two domains in commutative diagrams

Suppose I have following diagrams

\documentclass[article]{amsart}
\textheight 9.3in \textwidth 6.5in
\topmargin -1cm
\usepackage[all]{xy}\usepackage{amsmath,amsthm,amsfonts,amssymb}
\usepackage{hyperref}
\usepackage{mathrsfs}
\usepackage[all]{xy}

\pagestyle{myheadings}

\usepackage{xypic}

\begin{document}
\[\xymatrixrowsep{10mm} \xymatrixcolsep{10mm}
\xymatrix{
A \ar[r] \ar[d]  
& B \ar[d]\\ 
C \ar[r] 
& D}.\]

and 

\[\xymatrixrowsep{10mm} \xymatrixcolsep{10mm}
\xymatrix{
M \ar[r] \ar[d]  
& N \ar[d]\\ 
P \ar[r] 
& Q}.\]
\end{document}

I would like to get help for digram which has both of these diagrams side by side in the order above and a map from D to P and another map (curved map) from C to Q.

4

Make one diagram:

\documentclass{amsart}
\usepackage[all,cmtip]{xy}

\begin{document}
\[
\xymatrix{
A \ar[r] \ar[d] & B \ar[d] & M \ar[r] \ar[d] & N \ar[d]\\
C \ar[r] \ar@/_1.5pc/[rrr]& D \ar[r] & P \ar[r] & Q}
\]
\end{document}

enter image description here

Notes.

  1. There is no article option for amsart
  2. Loading xy twice is the same as loading it once
  3. \usepackage{xypic} is useless
  4. Don't do \topmargin-1cm, which means nothing; rather set the text width and height and issue \calclayout.

The same with tikz-cd:

\documentclass{amsart}
\usepackage{tikz-cd}

\begin{document}
\[
\begin{tikzcd}
A \arrow[r] \arrow[d] & B \arrow[d] & M \arrow[r] \arrow[d] & N \arrow[d]\\
C \arrow[r] \arrow[rrr,bend right] & D \arrow[r] & P \arrow[r] & Q
\end{tikzcd}
\]
\end{document}

enter image description here

1
  • Sir, I took your suggestion and removed that topmargin and other unnecessary things in that file. I did not change in other files and what i have written now is my usual format which is there for all texfiles i have written and i will edit in all tex files. From now, you would not see topmargin, \usepackage{xypic} things in my questions. :) :) thanks for the answer. I will delete this article class also. From now, it is only \documentclass{amsart} for me. Any other suggestion is welcome sir.
    – user43645
    Mar 2 '17 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy