5

In the following snippet one can observe unexpected behavior (at least to me)

\documentclass{scrbook}
\KOMAoptions{%
    headinclude,
    %footsepline=false
}
\recalctypearea
\usepackage{lipsum}
\begin{document}
    \chapter{bla}
    \section{blub}
    \lipsum[1-20]
\end{document}

The option headinclude includes the head to the text body, as expected. However, an additional option footsepline=false cancels the headinclude option and results in a way too small header margin. Interestingly headinclude remains, if the option footsepline=true is given.

How is this behavior explained?

EDIT: Interestingly the order of the options matters in this particular question. If footsepline=false is defined before headinclude it does not affect the header margin.

  • 1
    The supposed reason for KOMA was to create more beautiful documents based on theoretical formulas for beauty. – John Kormylo Mar 3 '17 at 3:11
  • The bug has been fixed. With current pre-release 3.23.2606 footsepline=false does not longer change headinclude (but footinclude to false which is already the default). Thank you for reporting the bug. – Schweinebacke Mar 3 '17 at 11:33
  • @Schweinebacke: Thanks for the clarifying comment. If you write the very same in an answer, I would be glad to mark it as accepted. – marlam Mar 3 '17 at 11:50
4

It was indeed a bug in KOMA-Script since v3.20. In typearea option footsepline has changed the setting of option headinclude instead of footinclude.

The bug has been fixed in pre-release 3.23.2606. See the German release information for KOMA-Script 3.22 or the change itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.