4

What does the error below mean and how I can fix it? I use www.sharelatex.com. My file main.tex has 100 rows.

\documentclass[10pt,a6paper]{book}
\usepackage[utf8]{inputenc}
\usepackage[main=slovak,english]{babel}
\usepackage[cm]{fullpage}
\usepackage[a6paper, top=15mm, left=10mm, right=10mm, bottom=10mm,foot=5mm,marginparsep=0mm]{geometry}
%showframe
\usepackage{tipa}
\usepackage{tabularx,booktabs}  %\toprule
\usepackage{listings}
\usepackage{multirow}
\usepackage{longtable}
%\usepackage{lscape}
\usepackage{wasysym} % symbols
\usepackage{amssymb} % symbols
%\usepackage{pdflscape}
%\usepackage{lscape}
\usepackage{hyperref}
\usepackage{marvosym}
\usepackage{framed}
\usepackage{wasysym}
\usepackage{pdflscape}
\usepackage{graphicx}
%\usepackage{amsmath}
\usepackage{color}
\usepackage{tabularx,booktabs}
\usepackage{rotating}
\usepackage{graphicx}
\usepackage{adjustbox}
\usepackage{mathtools}
\usepackage{array,multirow,graphicx}


\newcommand*{\knihaB}{\fontfamily{bch}\selectfont}
\newcommand*{\knihaA}{\fontfamily{phv}\selectfont}
\newcommand*{\knihaC}{\fontfamily{ccr}\selectfont}
\newcommand*{\knihaM}{\fontfamily{cmr}\selectfont}

\newcommand*{\knihaEa}{\fontfamily{qag}\selectfont}
\newcommand*{\knihaEb}{\fontfamily{phv}\selectfont}

\newcommand*{\knihacc}{\fontfamily{pag}\selectfont}
\newcommand*{\knihaaa}{\fontfamily{ccr}\selectfont}
\newcommand*{\knihabb}{\fontfamily{ccr}\selectfont}
%\usepackage{mathtools}
\renewcommand{\thesection}{\arabic{section}}

\begin{document}
\catcode`\-=12
\sloppy

%\clearpage
%\setcounter{secnumdepth}{0} 
%\setcounter{page}{1} 
%\tableofcontents
%\thispagestyle{empty}


{\large

%\input{alphb.txt}
%\input{pronouns.txt}
%\input{tobe.txt}
%\input{havegot.txt}
%\input{can.txt}
%\input{towas.txt}
%\input{could.txt}
%\input{had.txt}
%\input{wouldlike.txt}
%\input{casy.txt}
%\input{inqs.txt}
%\input{should.txt}
%\input{usedto.txt}
%\input{haveto.txt}
%\input{predl1.txt}

%\input{ukaz.txt}
%\input{clen.txt}
%\input{podm.txt}
%\input{ponep.txt}
%\input{mnozs.txt}
%\input{nep_1.txt}
%\input{privlast.txt}
%\input{pridm.txt}
%\input{wh_q.txt}
%\input{nz.txt}
%\input{zast_zam.txt}
%\input{deter.txt}
%\input{spoj.txt}
%\input{numbers.txt}
%\input{adverbs.txt}
%\input{theris.txt}
%\input{slovosled.txt}
%\input{rozkaz.txt}
%\input{week.txt}

}


\end{document}

enter image description here enter image description here

Thanks for help.

  • 1
    the command for a double integral has already been defined then you load amsmath which tries to define it again. probably wasysym, do you need both packages? (and why are you loading wasysym twice? you have commented amsmath out but it is included by mathtools. – David Carlisle Mar 2 '17 at 19:28
  • @DavidCarlisle I need package \usepackage{wasysym} because I use some symbols. What does tries to define it again mean? I'm not a computer programmer. :-) – Ľubomír Masarovič Mar 2 '17 at 19:34
  • 1
    if you go \newcommand\zzz{hello} it defines \zzz but if you do it again it gives an error that \zzz is already defined. anyway just put \let\iiint=\relax before you load mathtools and that will undefine it so mathtools will define it again – David Carlisle Mar 2 '17 at 19:36
  • @DavidCarlisle It doesn't work. – Ľubomír Masarovič Mar 2 '17 at 19:39
  • I removed the packages \usepackage{amsmath} and \usepackage{mathtools} and it works. It's alright. Thank you @DavidCarlisle . – Ľubomír Masarovič Mar 2 '17 at 19:50
11

The wasysym package also defines multiple integral symbols. You can load it with option [nointegrals] if you want to use the amsmath version, or [integrals] if you prefer the wasysym version.

I took the opportunity to clean your preamble: many packages were loaded several times. Also, you don't have to load amsmath if you load mathtools since the latter does it for you.

As your main language has accented letters, you must add \usepackage[T1]{fontenc} to ensure proper hyphenation.

Final comments: it's better to load xcolorthan color, as it can do more things, with option [table] if you intend to use colours in tables, and hyperref should be loaded as the last package, with very few exceptions (most notable cleveref).

\documentclass[10pt,a6paper]{book}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[main=slovak,english]{babel}
\usepackage[cm]{fullpage}
\usepackage[a6paper, top=15mm, left=10mm, right=10mm, bottom=10mm,foot=5mm,marginparsep=0mm]{geometry}
%showframe
\usepackage{tipa}
\usepackage{tabularx,booktabs} %\toprule
\usepackage{listings}
\usepackage{longtable}
\usepackage{amssymb} % symbols
\usepackage[nointegrals]{wasysym} % symbols
%\usepackage{pdflscape}
%\usepackage{lscape}
\usepackage{marvosym}
\usepackage{framed}
\usepackage{pdflscape}
\usepackage[table]{xcolor}
\usepackage{rotating}
\usepackage{adjustbox}
\usepackage{mathtools}
\usepackage{array,multirow,graphicx}
\usepackage{hyperref}    

\newcommand*{\knihaB}{\fontfamily{bch}\selectfont}
\newcommand*{\knihaA}{\fontfamily{phv}\selectfont}
\newcommand*{\knihaC}{\fontfamily{ccr}\selectfont}
\newcommand*{\knihaM}{\fontfamily{cmr}\selectfont}

\newcommand*{\knihaEa}{\fontfamily{qag}\selectfont}
\newcommand*{\knihaEb}{\fontfamily{phv}\selectfont}

\newcommand*{\knihacc}{\fontfamily{pag}\selectfont}
\newcommand*{\knihaaa}{\fontfamily{ccr}\selectfont}
\newcommand*{\knihabb}{\fontfamily{ccr}\selectfont}
%\usepackage{mathtools}
\renewcommand{\thesection}{\arabic{section}}

\begin{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.