1

I was used to using BibTeX for my bibliographies, but was convinced to switch to BibLaTeX. I use MikTeX, so I went through the trouble of finding and creating a typesetting shortcut for Biber, and I thought I was ready to go.

With the example below, the text compiles, but the citekeys show in bold, and no bibliography prints at all.

I tried updating MikTeX (didn't help, and now I can't seem to go back to BibTeX) I have run pdfLaTeX, Biber, pdfLaTeX, pdfLaTex, and other combinations numerous times. I Don't know what I could be doing wrong. Any insight?

I set up my file like this:

\documentclass[12pt]{article}
\usepackage[backend=biber, style=ieee]{biblatex}
\addbibresource{BibDB.bib}

\begin{document}
text text text \cite{smith2017computer}.

\printbibliography

\end{document}

The citation, in the file BibDB.bib looks like:

@article{smith2017computer,
    title={Computer stuff},
    author={Smith, John Q and Doe, Jane},
    journal={Computer Scientist},
    volume={34},
    number={12},
    pages={54--63},
    year={2017},
    publisher={Workhouse}
    }

When I run biber with this, I get the error message:

Cannot find control file 'Example.bcf'! - did you pass the "backend=biber" option to BibLaTeX?

The full .blg reads

[1] Config.pm:354> INFO - This is Biber 2.7
[2] Config.pm:357> INFO - Logfile is 'Example.blg'
[263] biber-MSWIN64:303> INFO - === 
[1951] Utils.pm:180> ERROR - Cannot find control file 'Example.bcf'! - did you pass the "backend=biber" option to BibLaTeX?
[1952] Biber.pm:113> INFO - ERRORS: 1

I did pass that argument, so I don't know what to do or how to fix it.

closed as off-topic by moewe, Stefan Pinnow, gernot, user36296, Torbjørn T. Mar 6 '17 at 17:47

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you edit in the .log and .blg files? – Joseph Wright Mar 4 '17 at 18:43
  • 2
    A pdfLaTeX run will always generate a .log. If you have extensions hidden then you may struggle to identify it: turn that off! The .logg and the .blg are both text files: open them with your TeX editor (and ignore the fact that Windows is confused by the extension). – Joseph Wright Mar 4 '17 at 18:53
  • 1
    Your code works for me, try deleting all the auxiliary files (of course, keep the .tex and .bib ones) and then run again pdflatex>biber>pdflatex>pdflatex. – CarLaTeX Mar 4 '17 at 19:09
  • 1
    @moewe, I have had to do a (full and complete) uninstall of MiKTeX, and I'm running TexWorks from TeXLive now. I'm also back to bibTeX, because I need to move forward with my project. I appreciate the help, thanks very much. – Aarow Mar 6 '17 at 14:39
  • 4
    I'm voting to close this question as off-topic because the OP removed and re-installed (another) the TeX distribution in the meantime, so that there is now no way to find out what caused the issue. – moewe Mar 6 '17 at 17:04

Browse other questions tagged or ask your own question.