This question already has an answer here:

I can't seem to insert Greek symbols in my beamer presentation. This is how the top section looks like

\setbeamertemplate{navigation symbols}{}
\usepackage{amsmath, amsthm}
\usepackage{listings}%% to include code
    language=Java, basicstyle=\footnotesize\ttfamily,

\addtobeamertemplate{block begin}{}{\justifying}
%here is a sample page
   \frametitle{Trial insert Greek Symbols}
        \item<1> \epsilon
        \item<2> Some text

Whenever I remove the \epsilon, my file compiles without error. When I add the \epsilon it produces this error "!Missing $ inserted. ,inserted text> $ \end{frame}" Also is there any specific arrangements when including a package in the latex file (E.g. A certain package should be above some other package while including in a file).


marked as duplicate by CarLaTeX, Symbol 1, Community Mar 5 '17 at 18:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    \epsilon should be used in math mode, you have to write $\epsilon$. – CarLaTeX Mar 5 '17 at 18:04
  • 1
    Some packages have to be loaded after other packages, the mots notable being hyperref , which has to loaded at the end (with some exceptions — mainly cleveref). – Bernard Mar 5 '17 at 18:05

Either you put your \epsilon in math mode ($\epsilon$) or you use a package such as textgreek and its \textepsilon.

(Last option would be using a unicode-capable engine like Xe/LuaLaTeX and inserting the unicode character).

Not the answer you're looking for? Browse other questions tagged or ask your own question.