1

I'm using the latest version of texlive on windows 10 with the latest version of texstudio (2.12.2). I've placed my universal library.bib file in C:\texlive\texmf-local\bibtex\bib\local and run texhash; so far so good.

Now if I create a tex file anywhere like so:

\documentclass[11pt,a4paper]{article}
\usepackage[british]{babel}
\usepackage{natbib}
\bibliographystyle{ouharvard}          % This is a custom bst I put in C:\texlive\texmf-local\bibtex\bst\local
\usepackage[hidelinks]{hyperref}
\urlstyle{same}

\begin{document}

    \cite{Blencowe2010}

    \bibliography{library}

\end{document}

Where Blencowe2010 is in my library.bib database, it works fine, however upon typing \cite{ I get no autocomplete suggestions and have to type the entry in by hand - this is an issue that google tells me used to exist in texstudio, but apparently got fixed a couple of years ago. I've found that changing the bibliography line to:

\bibliography{/texlive/texmf-local/bibtex/bib/local/library}

Will solve this issue, but from what I understand this shouldn't be required. Does anyone know a better solution?

2

I solved my own issue. Firstly in tex documents, paths must be expressed with forward slashes, else tex interprets them as commands. Next I had to go to "Options > Configure TeXstudio > Adv. Editor" and scroll down on this window. Under "Additional Search Paths > Bib Files" I added "C:\texlive\texmf-local\bibtex\bib\local" (no quotes).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.