5

I am trying to set up Texmaker, so I can use latexmk with xelatex, as biber seems already supported by latexmk. I confess I do not understand how I should proceed about it. For latexmk, I am actually using this command line:

latexmk -e "$pdflatex=q/xelatex -synctex=1 -interaction=nonstopmode/" -pdf %.tex.

I have also created and modified the file .latexmkrc as described in the list, but this should only work from the command line.

2
  • Does settings in .latexmkrc not affect latexmk run via Texmaker?
    – N.N.
    Commented Nov 22, 2011 at 9:00
  • @N.N. It seems not in my case, but I am not entirely sure. Sorry for the unhelpful answer Commented Nov 22, 2011 at 11:05

1 Answer 1

5

I've put that line (slightly modified) in a "user command" in Texmaker

latexmk -e "$pdflatex=q/xelatex -synctex=1 -interaction=nonstopmode/" -pdf %

and the document has been built successfully.

2
  • There also is an option -xelatex, but your version seems better because -xelatex might not include -synctex=1 -interaction=nonstopmode, which seems advisable for Texmaker.
    – doncherry
    Commented Oct 14, 2012 at 21:52
  • I have the same problem, and unfortunately the above solution doesn't work for me. In my case, it seems Biber cannot compile the bibliography for some reason. Latekmk complains "Missing bbl file" several times, and produces a pdf, but without the bibliography. If I manually compile with xelatex+biber+xelatex all is perfectly fine (and the bibliography appears!), so it seems it's a problem from the command given to latekmk from TexMaker, which is exactly the one given above. Maybe the program changed its command since?
    – Lempeo
    Commented Mar 15, 2023 at 17:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .