0

I'm using xindy for my acronyms (glossaries). However the command makeglossaries latex_file did not work. The following error was thrown:

xindy.pl: Cannot locate bin directory at C:\Users\GillesCallebautPC\AppData\Roaming\MiKTeX\2.9\scripts\xindy\xindy.pl line 415.

Setup: - Windows 10 (64-bit) - MikTex distribution - Xindy installed through MikTex Package Manager (admin)

  • Welcome to TeX.SX! Can you add some more information about your setup? – egreg Mar 7 '17 at 13:12
1

SOLUTION:

Remove all installed xindy related packages from the MikTex Package Manager (user). And install all xindy related package from the MikTex Package Manager (admin).

Old answer:

I've solved this issue by replacing some code in the xindy.pl file. I've replaced "$cmd_dir/../../miktex/bin/x64/internal" with "C:/Program Files/MiKTeX 2.9/miktex/bin/x64/internal" (located around line 406).

Hope this helps for people who will come across the same issue in the future.

  • There is no need to manually change xindy.pl (and it is not a good idea too). Deinstall your local versions of the xindy package with the package manager and reinstall it with the package manager (admin). – Ulrike Fischer Mar 7 '17 at 13:05
  • 1
    I know it is not a good idea to rely on a fixed location. But I've already tried reinstalling the package, without success. – gillesC Mar 7 '17 at 13:10
  • Well the same discussion just happend three days ago on the miktex list. xindy really should be installed only in the main (admin) tree. Check in the package manager (user) for all packages related to xindy and deinstall them. Then reinstall them with the package manager (admin). – Ulrike Fischer Mar 7 '17 at 13:13
  • Thank you for your comment. I was unaware of the difference between the user and admin package managers. Thought that the latter just had some admin rights, that's all. I will try your solution when the server is back. Currently I'm getting the following error: "Error response from server: 500", when installing via the admin package manager. – gillesC Mar 7 '17 at 13:27
  • The whole miktex site seems to be down. https://miktex.org/ doesn't answer either. – Ulrike Fischer Mar 7 '17 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.