2

I can't change the program that LyX uses to view pdfs. Currently LyX is using Xpdf to show pdf output, which is not an ideal program.

I've looked at other solutions to this problem and they have not worked. Changing the preferred viewer to xreader in preferences and then reconfiguring doesn't work. I would like to avoid changing files and stick to the LyX gui.

I'm using Linux Mint 18 Cinnamon 64-bit and Lyx 2.2.2.

Edit: Apparently if I export as a pdf, it opens it with xreader. Not sure why it insists on using xpdf when I hit the view eyeballs.

  • What exactly did you try? Do you know what flavor (e.g. pdflatex, xelatex), is being used when you click on the eyes button? If so, you need to change the viewer for that specific format. – scottkosty Mar 8 '17 at 6:17
  • I tried all the pdf options (pdflatex, xetex, luatex, etc), and they all used xpdf. How would I go about changing the viewer for specific formats? – fish_dots Mar 8 '17 at 6:42
  • 1
    Change the reader in Tools > Preferences > File Handling > File Formats > Viewer. Click on "save". Restart LyX. Do not reconfigure. It is possible that restores the default viewer. Does that work? – scottkosty Mar 8 '17 at 7:25
  • 1
    That doesn't fix it. Even after I reconfigure (previous attempts, not this one), it still shows xreader as the custom option for the viewer. There is only 'none' and 'custom' as options for the viewer. – fish_dots Mar 9 '17 at 2:49
  • Strange. I'm not sure what's going on. You could try the following: temporarily uninstall Xpdf, then reconfigure in LyX. Does it work now? Then you can reinstall Xpdf as long as you don't reconfigure in LyX. I just checked and actually it's strange that LyX doesn't use xreader, because in LyX's configure script, xreader is preferred to xpdf. So LyX might just have trouble finding it for some reason. – scottkosty Mar 9 '17 at 21:08
1

The problem is that LyX is not aware that xreader is a PDF viewer. For more information, see this mailing list thread.

For the solution, see this patch. Basically, just add xreader to the list of PDF viewers. On Ubuntu with the apt package, the configure script is located at /usr/share/lyx/configure.py.

This will be fixed in the next LyX version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.