1

I am using the command \parshape inside my document and it doesent seem to work. Any ideas why?

\documentclass[10p, a4paper, twopage]{book}
\usepackage{lipsum}

\begin{document}

\parshape=10 
0.25\hsize 0.5\hsize 
0.24\hsize 0.52\hsize 
0.23\hsize 0.54\hsize 
0.22\hsize 0.56\hsize 
0.21\hsize 0.58\hsize 
0.20\hsize 0.6\hsize 
0.19\hsize 0.62\hsize 
0.18\hsize 0.64\hsize 
0.17\hsize 0.66\hsize 
0.16\hsize 0.68\hsize

\lipsum[1]

\end{document}

It does not throw any errors, the text is just not formatted in any way.

And also, is there a way to optimize all that command writing (parshape parameters)?

  • An empty line inserts \par; the command \par resets \parshape to 0. – egreg Mar 8 '17 at 18:37
1

The text that should be shaped should immediately follow the \parshape setting:

enter image description here

\documentclass{article}

\usepackage{lipsum}

\begin{document}

\sloppy

\parshape 10 
0.25\hsize 0.5\hsize 
0.24\hsize 0.52\hsize 
0.23\hsize 0.54\hsize 
0.22\hsize 0.56\hsize 
0.21\hsize 0.58\hsize 
0.20\hsize 0.6\hsize 
0.19\hsize 0.62\hsize 
0.18\hsize 0.64\hsize 
0.17\hsize 0.66\hsize 
0.16\hsize 0.68\hsize
\lipsum[1]

\end{document}
  • I removed your class usage since it's wrong. There are no 10p or twopage options for document class book. Also, be careful of using \lipsum[1] since it necessarily places a paragraph. If you don't want this, it may sometimes help to use \lipsum*[1] or call \usepackage[nopar]{lipsum}. – Werner Mar 8 '17 at 18:36
  • Thank you very much for your help! This works great now! – Redstone Tehnik Mar 8 '17 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.