0

I'm creating a beamer presentation that uses biblatex with biber and the ieee style with dashed=false to suppress dashing of repeat author names. This compiles find on my MikTeX installation on my laptop, but will not compile on Overleaf.

Further testing on other web-based compilers showed that no TeX live installation recognises the dashed option, with any document class.

MWE:

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[backend=biber, style=ieee, dashed=false]{biblatex}

\begin{document}

\end{document}

How can I get dashed to work with TeX live?

  • 1
    It works in texlive 2016 but not in 2015. The web-based compilers are quite often a bit outdated. You would need to get an updated version of the style, but I can't tell you if it would work with an older biblatex. – Ulrike Fischer Mar 9 '17 at 10:37
  • Thanks, I feared that would be the case. Looks like there's not much I can do, but I don't use Overleaf too much anyway – Utumno Mar 9 '17 at 12:34
  • according to tex.stackexchange.com/questions/357372/… overleaf uses texlive 2016, but not up-to-date but the one from ubuntu – user36296 Mar 9 '17 at 13:05
1

The dashed option was added to biblatex-ieee in version 1.2 released 2016-12-26 (with this commit following discussion on the bugtracker).

Overleaf are currently running biblatex-ieee on version 1.1p from 2016-07-20, so that version does not have the dashed option. I assume that some other online compilers might be similarly behind with their versions.

If you want to use the dashed option with older versions, add

\makeatletter
\DeclareBibliographyOption[boolean]{dashed}[true]{%
  \ifstrequal{#1}{true}
    {\ExecuteBibliographyOptions{pagetracker}%
     \renewbibmacro*{bbx:savehash}{\savefield{fullhash}{\bbx@lasthash}}}
    {\renewbibmacro*{bbx:savehash}{}}}
\makeatother

and then

\ExecuteBibliographyOptions{dashed=false}

to your preamble. (You still can't use dashed=false as loading-time option though, because at that moment the option is unknown - it is only defined later in your document.)

On Overleaf https://www.overleaf.com/read/fspxdskjwpsm

Or use one of the solutions offered in Enabling dashed option for biblatex-ieee style and biblatex ieee style same authors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.