5

I have no idea what happedned. This code worked just couple of days ago. Now suddenly it stopped with an error which I don't understand at all

 ! Missing \endcsname inserted. <to be read again> 
 \def  l.252 ...   \UnicodeEncodingName {}{"007E}
 ?

Can anyone help me with that ? This is my code:

\documentclass[a4paper,10pt]{article}

\usepackage{marvosym}
\usepackage{color}
\usepackage{fontspec}           %load fonts
\usepackage{url,parskip}            %formatting
\usepackage{xunicode,xltxtra}   %other packages for XeTeX
\usepackage[polish]{babel}
\usepackage{graphicx}
\usepackage{multirow}
\usepackage{geometry}

%Graphics - Colors
\RequirePackage{color,graphicx}
\usepackage[usenames,dvipsnames]{xcolor}
\usepackage[big]{layaureo}

\usepackage{soul}
\usepackage{scrpage2}

\usepackage{supertabular}       %for Grades
\usepackage{titlesec}           %custom section

%Setup hyperref package, and colours for links
\usepackage{hyperref}
\definecolor{linkcolour}{rgb}{0,0.2,0.6}
\hypersetup{colorlinks,breaklinks, urlcolor=linkcolour, linkcolor=linkcolour}

%FONTS
\defaultfontfeatures{Mapping=tex-text}
\setmainfont[SmallCapsFont = Corbel]{Corbel}

\titleformat{\section}{\large\scshape\raggedright}{}{0em}{}[\titlerule]
\geometry{verbose,a4paper,tmargin=2cm,bmargin=1cm,lmargin=2cm,rmargin=2cm}


\newenvironment{cvheader}%
    {\begin{tabular}{p{0.22\textwidth} p{0.55\textwidth} p{0.15\textwidth}}%
    }%
    {\end{tabular}}%



%-------BEGIN DOCUMENT--------

\begin{document}
\pagestyle{empty} % non-numbered pages

\setcounter{secnumdepth}{-1 }

 %--------------------TITLE-------------

\vspace*{ -26 mm}
\par{\centering {\Huge \textbf{Emilia Samul} \\
{\color{MidnightBlue}
\fontspec{Eutemia I Italic}
\huge Curriculum Vitae
\\[10pt]\par}
{\color{white} \hrule} %does this rule really change anything?
}\par} 

\vspace{-14 mm}
\section{\color{NavyBlue} INFORMACJE OSOBISTE}
%\begin{tabular}{rl}
\begin{cvheader}
\textsc{Data i miejsce urodzenia:} & 28.03.1986, Łuków &  \multirow{5}{*}{\includegraphics[width=2.2cm]{cvz.jpg}} \\
\textsc{Adres:} & 20-020 Lublin, ul.Lipowa 23/3\\
\textsc{Telefon:}   & +48 791 039 400 \\
\textsc{Email:} &  \href{mailto:emilia.samul@gmail.com}{\color{MidnightBlue}emilia.samul@gmail.com}\\
\end{cvheader}
%\end{tabular}


\section{\color{NavyBlue} DOŚWIADCZENIE ZAWODOWE}
\begin{tabular}{r|l}
\textsc{od XI.2011} & \textbf{Podinspektor d/s księgowości w Zakładzie Wodociągów i Kanalizacji w Wiązownie} \\
&Dekretacja oraz księgowanie dokumentów w programie FK firmy "ETOBRES" \\
&Uzgodnienie obrotów i sald kont, analityki przychodów i kosztów na koniec każdego miesiąca\\
&Terminowe przygotowanie sprawozdań\\
\end{tabular}


\vspace{-2 mm}
\section{\color{NavyBlue} OSIĄGNIĘCIA I UMIEJĘTNOŚCI}
\begin{itemize}
\vspace{-2 mm}
\item czynne \textbf{prawo jazdy} kategorii\textbf{ B} 
\end{itemize}

\vspace{-3 mm}
\section{\color{NavyBlue} ZAINTERESOWANIA}
\begin{tabular}{rl}
\textsc{MALOWANIE:} & głównie pejzaże farbami olejnymi \\
\textsc{FILM:}  &  Kino europejskie \\
& Gry logiczne \\
\end{tabular}

\end{document}
  • 1
    this means that you have an old format but a new tuenc.def (which is only distributed with the format) so most likely you use miktex and have updated user and not admin or (equivalently) use texlive and have used fmtutil instead of fmtutl-sys – David Carlisle Mar 9 '17 at 18:36
  • @DavidCarlisle, I recently got a similar error when I updated using tlmgr-gui on a Windows machine. Do you have a possible solution? – Khalid Hussain Mar 19 '17 at 3:37
  • @KhalidHussain I don't know the gui but the issue will bet the same, you need to delete any formats that have been built in your area and rebuild the system ones. Check that every latex document has a 2017 date in its startup banner, if it does not your tex system is badly configured and this error is just a symptom. It can not occur in a properly configured system. – David Carlisle Mar 19 '17 at 8:52
  • I had this problem too and I tried everything possible with no success. I ended up reinstalling the whole texlive. So please be advised that there is always this solution at least. – zyy Oct 18 '18 at 3:15
3

I recently got the same error and this is how I resolved it.

The error is due to an inconsistency between LaTeX and format files (I don't understand it completely). I will assume TeX Live 2016 is used. I have only tried the Windows solution but I assume the command will work the same on OSX and Linux.

If on OSX or Linux, at the terminal, type

sudo fmtutil-sys --all

If on Windows, open a command-prompt at

C:\texlive\2016\texmf-dist\scripts\texlive

and type

fmtutil-sys -all

Source: Erors rebuilding format after updating TexLive 2016 with tlmgr

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.