I'm trying to add a \listoftodos using the todonotes package to a template file I have. I've added two todos with \todo[inline]{Write abstract \ldots} and \todo{Fill in these details \ldots}. I'm using TextMate to render my document on Mac Osx.

My list of todos in my document looks like this: TODO List

My table of contents (in Estonian) looks like this (I think it might be interfering with the styling): enter image description here

And finally, the intended behaviour and styling from todonotes documentation looks like this with hyperlinks and colors: enter image description here

Do you have any ideas how to debug the styling issues with rendering todos?


1 Answer 1


Add the option [colorinlistoftodos] to your documentclass, see 1.2 Package options,p.4:colorinlistoftodos.


Adds a small colored square in front of all items in the Todo list.

For hyperlinks you nedd \usepackage{hyperref} or without box \usepackage[hidelinks]{hyperref}.

enter image description here





\todo[color=green!40]{And a green note}
test text \todo{test}
\todo{Make a cake \ldots}
\todo[linecolor=green!70!white, backgroundcolor=blue!20!white,
bordercolor=red]{Anything but default colors}
  • Great, I see the colors now! But I'm still missing the hyperlinks to the todos... Do you have the hyperlinks in your doc?
    – craastad
    Mar 11, 2017 at 10:28
  • Do you mean \usepackage{hyperref} or \usepackage[hidelinks]{hyperref}?
    – Bobyandbob
    Mar 11, 2017 at 10:39
  • 1
    @craastad Be careful, if your document is typeset in draft mode (i. e. you have given the option \documentclass[draft,...]{scrartcl}, hyperlinks won't be activated. just replace draft with final and everything should be fine.
    – Jan
    Mar 11, 2017 at 10:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .