-1

Can someone help me with this thing? when I type in TexMaker this command:

\hspace{15pt}Two things are infinite: the universe and human stupidity; and I'm not sure about the universe.

in pdf is written like this: enter image description here

How can I remove those spaces?

  • 3
    Could you provide a complete minimal example, of your document class and the (relevant) packages? Otherwise we probably cannot help you, since this seems to be related to your classes justification setting. – Timm Mar 11 '17 at 12:24
  • 1
    I can't reproduce this with a normal article document. – user31729 Mar 11 '17 at 12:25
  • 1
    Welcome to TeX.SE. Please tell us which document class you use and which commands come immediately before and immediately after the code snippet you've posted so far. – Mico Mar 11 '17 at 12:32
  • you have \parfillskip set to 0pt (which is far from being the default setting) (why the \hspace ?) – David Carlisle Mar 11 '17 at 12:41
5

You must have something equivalent to

\documentclass{article}

\begin{document}

\setlength\parfillskip{0pt}

\hspace{15pt}Two things are infinite: the universe and human stupidity; 
and I'm not sure about the universe.
\end{document}

which makes

enter image description here

If you remove the \hspace and remove the setting of \parfillskip which is specifying that the last line of the pargarph must reach the right margin, then you get

\documentclass{article}

\begin{document}

Two things are infinite: the universe and human stupidity;
and I'm not sure about the universe.
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.