3

I have set that

    \lineskiplimit = 6pt
    \lineskip=6pt

in the very begin of my Chinese document to prevent the space between above-and-below inline math from being too narrow. But the content in the list environment are not affected by them. So how can I make the global \lineskiplimit and \lineskip settings still work in the sub environment, such as list? Is something like below an ideal way?

\begin{list}{(\roman{iItemcounter})}
{\usecounter{iItemcounter}
\itemsep =0pt\parsep=0pt\parskip=0pt\topsep=0pt\leftmargin = 5em\rightmargin = 1em\lineskiplimit = 6pt\lineskip=6pt}{
\item ...
\item ...
}
\end{list}

UPDATE:

I'm sorry that I just found that the problem does not belong to the list environment, but the minipage. I surrounded the list by the minipage.

  • are you really sure you want to set lineskiplimit to 6pt??????????? – David Carlisle Mar 12 '17 at 12:15
  • if \lineskip ends up being used at all it is usually a sign of a failure of the text to fit the constraints of the document layout, increasing the value just magnifies the unpleasant effects of the discontinuity in the baseline spacing. It is hard to say without any example but there must be a better way. – David Carlisle Mar 12 '17 at 12:25
  • @DavidCarlisle I'm typesetting a Chinese document for senior high and I have a lot of special design for it (to suit the custom for Chinese readers), so.... – Eric Mar 12 '17 at 12:31
  • ah it may make sense with Chinese:-) (perhaps) Although increasing \baselineskip would give more consistent spacing even then. I'll post an answer:-) – David Carlisle Mar 12 '17 at 12:43
  • actually \lineskip` is set in parboxes but I don't see why it should be reset in a list? – David Carlisle Mar 12 '17 at 12:48
4

In general \lineskip is to be avoided, at least when typesetting with latin based scripts, but in comments you indicated this is Chinese about which I know nothing so...

latex has

\def\normalbaselines{\lineskip\normallineskip
  \baselineskip\normalbaselineskip \lineskiplimit\normallineskiplimit}

so you should set \normallineskip and \normallineskiplimit to your 6pt values.

You provided no example but in parbox and minipage \lineskip is reset to \normallineskip so you would lose a setting if you only set \lineskip at the start of the document, but I don't see why the default list setting should rest that, but perhaps your class redefines things. Hopefully though it resets to the
\normallineskiplimit value.

  • Yes. I'm sorry that I just found that the problem does not belong to the list environment, but the minipage. I surrounded the list by the minipage. You are so bright and detective. Even I has made a mistake, I also learn the usage of \normallineskip from your answer. Thanks! – Eric Mar 12 '17 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.