1

How can I set the -output-directory option in texify.exe.

Code below run fine without -output-directory option (purposely splitted the argument for better readability):

C:\Program Files\MiKTeX 2.9\miktex\bin\x64>texify.exe 
--include-directory="D:\DebuggingUse\TexStudio\latexPDFTesting" 
--job-name="LatexPDF" 
--batch 
--clean 
--max-iterations=2 
--pdf 
--quiet 
"D:\DebuggingUse\TexStudio\latexPDFTesting\document.tex"

Code after -output-directory added cannot run with error (Sorry, but "MiKTeX Compiler Driver" did not succeed.):

C:\Program Files\MiKTeX 2.9\miktex\bin\x64>texify.exe 
--include-directory="D:\DebuggingUse\TexStudio\latexPDFTesting" 
--job-name="LatexPDF" 
--batch 
--clean 
--max-iterations=2 
--pdf 
--quiet 
--tex-option=-output-directory="D:\DebuggingUse\TexStudio\latexPDFTesting" 
"D:\DebuggingUse\TexStudio\latexPDFTesting\document.tex"

I have tested --tex-option=-output-directory="samplepath" and -output-directory but with no success.

Thus, is there any other option to specify output-directory.

  • 1
    I never use texify or --output-directory (both for good reasons) but imho it did work once for relative pathes so you could try a bug report at the miktex site. It shouldn't work for absolute pathes for security reasons unless you change an environment variable. – Ulrike Fischer Mar 13 '17 at 8:41
  • Hi Ulrike, can i know why it shouldn't work for absolute path for what kind of security reason, just out of curiosity? Besides, which environment variable to change if i want to do that? – vincent911001 Mar 13 '17 at 8:57
  • Do you want texify to be able to write into /my/other/important/project/folder and perhaps destroy files there? tex.stackexchange.com/a/12453/2388 – Ulrike Fischer Mar 13 '17 at 9:17
  • @UlrikeFischer, Thanks for your explanation, so even though i could create a clean folder specifically for Tex output usage, i still shouldn't do it? BTW, currently i am using pdflatex directly to solve this issue as it allows include and output directory. – vincent911001 Mar 14 '17 at 0:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.