1

I tried

\DefineBibliographyStrings{french}{
  urldate = {page consultée le},
}

in Overleaf but I'm getting this error

Package xkeyval Error: `urldate' undefined in families `blx@lbx'.

I'm using polyglossia and not babel. No inputenc nor UTF8. XeLaTeX.

OK, switched from urldate to urlseen and that fixed one issue. But once I used this:

\DeclareFieldFormat{urldate}{%
\thefield{urlday}\adddot\addspace%
\mkbibmonth{\thefield{urlmonth}}\adddot\addspace%
\thefield{urlyear}\isdot}

It stopped working.

  • 1
    Can you make a compilable MWE? – samcarter_is_at_topanswers.xyz Mar 13 '17 at 13:02
  • 2
    Shouldn't it be urlseen instead of urldate? – David Purton Mar 13 '17 at 13:14
  • OK, I switched it to urlseen and it worked but once I added \DeclareFieldFormat{urldate}{%\thefield{urlday}\adddot\addspace%\mkbibmonth{\thefield{urlmonth}}\adddot\addspace%\thefield{urlyear}\isdot} to the preameble it's not working anymore. – Xyd Mar 13 '17 at 14:34
1

The correct string is urlseen and not urldate as can be seen from

\DeclareFieldFormat{urldate}{\mkbibparens{\bibstring{urlseen}\space#1}}

so you need

\DefineBibliographyStrings{french}{
  urlseen = {page consultée le},
}

For the date you probably want

\DefineBibliographyExtras{french}{%
  \protected\def\mkbibdatelong#1#2#3{%
    \iffieldundef{#3}
      {}
      {\thefield{#3}%
       \iffieldundef{#2}{}{\nobreakspace}}%
    \iffieldundef{#2}
      {}
      {\mkbibmonth{\thefield{#2}}%
       \iffieldundef{#1}{}{\space}}%
    \iffieldbibstring{#1}
      {\bibstring{\thefield{#1}}}
      {\dateeraprintpre{#1}\stripzeros{\thefield{#1}}}}}

together with the option urldate=long.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.