1

I would like to manually install \usepackage{emerald} in my macOS Sierra. In my Windows OS, Miktex does a good job via install-on-fly feature but this is not the case with Tex live. A suggested GUI for this matter is tex live utility but I've downloaded it and Xcode throws some errors. I don't have enough time to debug it, so I'm looking for the right way to manually install a package in Sierra. I've searched for how to download packages manually but the posts describe old versions of Mac (i.e. paths don't exist in my OS). The only post worked is this How do I install a LaTeX .sty file on OSX? but the font in the following code is not generated. I suspect the way packaged installed since the font is generated in my Windows OS but unfortunately my laptop is at computer repair shop and I'm forced to use my Mac.

\documentclass{article}
\usepackage{emerald}
\usepackage[T1]{fontenc}

\begin{document}

\ECFWebster Results 
\end{document}

The expected output is

enter image description here

But in my Mac, the output is

enter image description here

  • Is there any error or warning in the Log? It seems, as if they font itself isn't installed on your Mac. – Jan Mar 13 '17 at 16:31
  • I get these warnings LaTeX Font Warning: Font shape 'T1/fwb/m/n' undefined (Font) using 'T1/cmr/m/n' instead on input line 7. [1 {/usr/local/texlive/2015/texmf-var/fonts/map/pdftex/updmap/pdftex.map}] (./main.aux) LaTeX Font Warning: Some font shapes were not available, defaults substituted. – CroCo Mar 13 '17 at 17:34
  • This points into my first direction. Your TeX-system was not able to find the font fwb, which is defined by the package emerald. – Jan Mar 14 '17 at 8:03
1

First download the emerald.zip file from CTAN and un-zip it. Then download the `TeXLive2014+Changes.pdf.zip' document from <https://herbs.github.io> and look at the section on installing fonts

  • I've created updmap.cfg and typed Map emerald.map with a black new line. I don't have this folder texmf-local/fonts/map I just created it and place emerald.sty inside it. I run sudo -H mktexlsr and sudo -H updmap-sys . I still get this LaTeX Error: File 'emerald.sty' not found. – CroCo Mar 13 '17 at 17:30
  • In Terminal change directory (cd) to /usr/local/texlive/texmf-local and work from there. If you don't like to use Terminal click on the Go menu in Finder and the the Go To Folder... item. Then enter /usr/local/texlive and press Return to open that folder in Finder. You can then work from there. – Herb Schulz Mar 13 '17 at 17:45
  • I got these errors updmap [ERROR]: The following map file(s) couldn't be found: updmap [ERROR]: emerald.map (in /usr/local/texlive/texmf-local/web2c/updmap.cfg) updmap [ERROR]: Did you run mktexlsr? – CroCo Mar 13 '17 at 18:26
  • As the document says, if you put the files in the /usr/local/texlive/texmf-local root you need to run sudo -H updmap-sys rather than updmap. After you do that you'll now have to delete ~/Library/texlive/2016. To open ~/Library hold the Opt key down while clicking on the Go menu in Finder and a new menu item to open that folder will appear. – Herb Schulz Mar 13 '17 at 18:46
  • Are your sure about deleting 2016? If I do so, I can't run mktexlsr nor updmap-sys. Also, after unzipping emerald, where should I put the files? there is no map folder. I've created one and placed them there and the errors gone but still missing the package if I run my code. – CroCo Mar 13 '17 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.