2

When I compile LaTex, it normally installs missing packages. But \usepackage{siunitx} does not do so. Even it asks me for installation permission, when I accept yes, it automatically close saying latex.exe has stopped running.

I have seen similar problem asking here, but I could not get the point how to solve my problem.

Can someone please help for this issue?

  • Which LaTeX distribution do you have? Try installing the package using your package manager? – Troy Mar 20 '17 at 0:35
  • I have MiKTeX 2.9, 64-bit . Can you please tell me how can I use package manager option? – Frey Mar 20 '17 at 1:05
  • 3
    Go to Start, and search for Miktex, you should see an option MikTeX Package Manager (Admin) pop up. (Otherwise go to the directory where you installed MikTeX to try and find it.) It's important that you open the Admin version, btw. Then on the options above, go to Repository -> Change Package Repository -> ... Install from the Internet -> Choose any one. It will go ahead and synchronize the repository. After that, look for siunitx within the package manager, and install it. – Troy Mar 20 '17 at 3:05
  • 3
    Once that's done, use Start and find MikTeX settings (Admin), and refresh FNDB and update formats. Then try running your .tex file again – Troy Mar 20 '17 at 3:09
5

General Guide to Installing Packages with MikTeX Package Manager

If you have trouble with installing packages during compilation, try to install the package via the Package manager from your TeX distribution (MikTeX, TeXlive etc.) instead.

Here I present the steps to be taken for MikTeX 2.9, Windows 7/8/10 (since that is what you have installed):

  1. Go to Start, and search for MikTeXyou should see an option that says MikTeX Package Manager (Admin) pop up. Otherwise go to the directory where you installed MikTeX to try and find it. It's important that you select the (Admin) version, and not the one that just says MikTeX Package Manager.

enter image description here

  1. From the options tab of the package manager, go to Repository -> Change Package Repository -> ... Install from the Internet -> *Choose any one*. Note: if an error pops up at this stage, try the other repositories.

step2

  1. Allow the repository to synchronize.
  2. Once the repository is synchronized, go ahead and search for the package you want (siunitx) from within the Package manager. Right click it, and proceed with installation.

step4

  1. Once installation is done, go to Start and find MikTeX Settings (Admin). Do both: 'Refresh FNDB' and 'Update Formats'. Then you're done.

step5


In general, when you want to install new packages, I would advise going through all of these steps especially if it has been some time since you updated/ installed a new package (because the repository that you have synced with last would probably be outdated).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.