2

The package showframe.sty seems not to play nicely with memoir.cls. A minimum example where the displayed main frame box doesn't coincide with the position of the main body text:

\documentclass[a4paper]{memoir}

\textwidth = 12.2cm
\textheight = 19.8cm
\oddsidemargin = 1.95 cm
\evensidemargin = 1.95 cm
\topmargin = 2.1cm

\usepackage{blindtext,showframe} 
\begin{document}

\Blindtext
\Blindtext

\end{document}

(Things only get worse with the frames for headers not matching custom-designed headers, etc.)

All I want to be able to do is to show (for editing purposes) the frame surrounding the main body text on a page. Indeed, all I really need is to be able to show the location of the bottom of the main textbox. Any easy way of doing this?

  • Can you provide an MWE with the textbox you would like to 'highlight'? – Troy Mar 20 '17 at 14:50
  • I just mean showing the boundaries of the box containing the main body of the text. Nothng fancy! – Peter Smith Mar 20 '17 at 14:54
  • 1
    The document \documentclass{memoir} \usepackage{blindtext,showframe} \begin{document} \Blindtext \end{document} does not show any problems with the interplay between memoir and showframe. So it is difficult to answer your question as long as it is unclear what the problem is. – gernot says Reinstate Monica Mar 20 '17 at 14:55
  • Example now given -- use memoir to do memoir-ish things with non-default settings for page layout and it seems things go wrong with showframe – Peter Smith Mar 20 '17 at 15:07
  • 1
    Okay, +1 for the MWE. Try \usepackage[showframe, pass]{geometry} and see if it achieves your goal – Troy Mar 20 '17 at 15:12
3

You can try the showframe option from the geometry package instead. If you're using memoir's options to configure your page margins, then you need to pass the option pass when loading geometry to prevent it from messing up your margin settings. Here's an MWE:

\documentclass[a4paper]{memoir}

\textwidth = 12.2cm
\textheight = 19.8cm
\oddsidemargin = 1.95 cm
\evensidemargin = 1.95 cm
\topmargin = 2.1cm

\usepackage{blindtext}
\usepackage[showframe,pass]{geometry}
\begin{document}

\Blindtext
\Blindtext

\end{document}

geometry showframe option


Minor Edit:

Due to the discussion in the comments, I've decided to input the problem which I believe OP is facing. (The 'conflict' between memoir and showframe packages).

wrong showframe..

  • Memoir has own way to determine page layout, so use geometry is not special advantage. To see page layout, in preamble just add package, showframe: \documentclass[a4paper]{memoir} \usepackage{showframe} \begin{document} Hello! \end{document} – Zarko Mar 21 '17 at 9:55
  • @Zarko According to OP, the showframe package was not working fine for him, so I suggested a separate solution with the geometry package. I'm not too sure why the showframe package doesn't work though, if you have a way to make the showframe package work as OP's intended, please feel free to post a separate answer :) p.s. OP changed his margins. – Troy Mar 21 '17 at 10:09
  • If the claim of OP is true, than he has problem with some other package than memoir. This is worth to investigate. I so far, regardless that i very frequently use memoir, didn't experienced such a case. – Zarko Mar 21 '17 at 10:16
  • @Zarko Have you tried using OP's code? I don't get the frames surrounding the text using the showframe package as I do with geometry's showframe option. And I'm pretty sure my memoir package is updated, as is my distribution etc. – Troy Mar 21 '17 at 10:22
  • I test OP MWE. Frame normally show up. – Zarko Mar 21 '17 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.