0

I'm working on a two-column book.

The Table of Contents is in a two-column mode, which is good. But I'd like the List of Tables to spread over one-column (mainly because some of the tables have really long captions). Unfortunately, I can't figure out how to make that work.

Any suggestion would be appreciated. Thank you.

enter image description here

% PREAMBLE %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\documentclass[a4paper,oneside,centered,twocolumn]{book}
\special{papersize=210mm,297mm}
\usepackage[top=3cm, bottom=3.2cm, left=2.5cm, right=2.5cm]{geometry}

\usepackage[english]{babel}
\usepackage{newpxtext} % Font for document instead of obsolete Palatino
\usepackage{tocloft} % Customization of TOC LOF LOT
\usepackage[table,xcdraw]{xcolor} % For shading in tables
\usepackage{pdfcolmk}
\usepackage{multirow}
\usepackage{textcomp}
\usepackage{pdfpages}
\usepackage{ltablex}
\usepackage{nicefrac} % to write fractions
\usepackage{attrib} % For source of quotations
\usepackage{lettrine} % For NewThought formatting
\usepackage{array} % To define width of columns in long table
\usepackage{booktabs} % Nicer spacing in columns
\usepackage{siunitx} % To write Celsius, etc.
\usepackage{enumitem} % To create item lists
\usepackage{caption} % To change way captions are labelled
\usepackage{scrextend}
\usepackage{threeparttable} % For table notes + To allow footnote material to stay with the tabular environment
\usepackage{etoolbox} % To make table footnote font smaller
\usepackage{threeparttablex}
\appto\TPTnoteSettings{\footnotesize}
\usepackage{textcomp} % For Numero symbol

%To make TOC into two columns ... but then LOT disappears?
\usepackage[toc,lot]{multitoc}
\renewcommand*{\multicolumntoc}{2}
\renewcommand*{\multicolumnlot}{2}

\usepackage{hyperref} % Hyperlinks

\usepackage{blindtext}
%\usepackage{showframe}

\begin{document}

%\layout    

% FRONTMATTER STARTS %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\frontmatter

\tableofcontents
\clearpage

\addcontentsline{toc}{section}{\listtablename}
\listoftables

\clearpage

% MAINMATTER STARTS %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\mainmatter

\chapter{Chapter Title}

\section{A Huge Section}

\blindtext

\begin{table*}
    \centering
    \caption{Table of the Huge Section}\label{Table of the Huge Section}
        \begin{tabular}{lccr}\toprule
        \hline
        1 & 2 & 3 \\ \hline
        4 & 5 & 6 \\ \hline
        7 & 8 & 9 \\
        \hline
    \end{tabular}
\end{table*}

\end{document}
10
  • 1
    Should be similar to tex.stackexchange.com/questions/353866/…, but the other way round ;-)
    – user31729
    Mar 21, 2017 at 17:37
  • Hi. Tried to removed the following line from the above code "\renewcommand*{\multicolumnlot}{2}" and use the technique you link to. To no avail. I also tried to input 1 instead of 2 in the same line of code, "\renewcommand*{\multicolumnlot}{2}", again without success. Mar 21, 2017 at 17:44
  • Of course multitoc uses a different strategy. Do you really need that package at all?
    – user31729
    Mar 21, 2017 at 17:47
  • 2
    Consider use \caption[very short caption]{really long caption} before of force the layout. Often there are not a good reason to include long captions in the list, as this should be an index to help the reader to search tables, not a pseudo-summary of your work.
    – Fran
    Mar 21, 2017 at 17:53
  • I'm using "multicol" because it helps me put the Table of Contents into a two-column mode. I successfully use the \onecolum \twocolumn opposition around the tables that appear in the rest of the document. Some of these are one-column, multi-page tables, and that technique works. Mar 21, 2017 at 18:06

1 Answer 1

0

There is a bug in multitoc. I also ignore the [toc,lot,lof] options as they serve no useful purpose.

You can extend this to new toc types using \newcommand{\multcolumnXXX}{2}.

\documentclass[a4paper,oneside,centered,twocolumn]{book}
\special{papersize=210mm,297mm}
\usepackage[top=3cm, bottom=3.2cm, left=2.5cm, right=2.5cm]{geometry}

\usepackage[english]{babel}
\usepackage{newpxtext} % Font for document instead of obsolete Palatino
\usepackage{tocloft} % Customization of TOC LOF LOT
\usepackage[table,xcdraw]{xcolor} % For shading in tables
\usepackage{pdfcolmk}
\usepackage{multirow}
\usepackage{textcomp}
\usepackage{pdfpages}
\usepackage{ltablex}
\usepackage{nicefrac} % to write fractions
\usepackage{attrib} % For source of quotations
\usepackage{lettrine} % For NewThought formatting
\usepackage{array} % To define width of columns in long table
\usepackage{booktabs} % Nicer spacing in columns
\usepackage{siunitx} % To write Celsius, etc.
\usepackage{enumitem} % To create item lists
\usepackage{caption} % To change way captions are labelled
\usepackage{scrextend}
\usepackage{threeparttable} % For table notes + To allow footnote material to stay with the tabular environment
\usepackage{etoolbox} % To make table footnote font smaller
\usepackage{threeparttablex}
\appto\TPTnoteSettings{\footnotesize}
\usepackage{textcomp} % For Numero symbol

%To make TOC into two columns ... but then LOT disappears?
\usepackage{multitoc}
\makeatletter
\renewcommand*{\@starttoc}[1]{\bgroup% use locak registers
   \@ifundefined{multicolumn#1}{\count1=1}{\count1=\csname multicolumn#1\endcsname}%
   \ifnum\count1>1
     \begin{multicols}{\count1}%
       \@multitoc@starttoc{#1}%
     \end{multicols}%
   \else
     \@multitoc@starttoc{#1}%
   \fi
\egroup}%
\makeatother

\renewcommand{\multicolumnlot}{1}

\usepackage{hyperref} % Hyperlinks

\usepackage{blindtext}
%\usepackage{showframe}

\begin{document}

%\layout    

% FRONTMATTER STARTS %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\frontmatter

\tableofcontents
\clearpage

\addcontentsline{toc}{section}{\listtablename}
\listoftables


% MAINMATTER STARTS %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\mainmatter

\chapter{Chapter Title}

\section{A Huge Section}

\blindtext

\begin{table*}
    \centering
    \caption{Table of the Huge Section}\label{Table of the Huge Section}
        \begin{tabular}{lccr}\toprule
        \hline
        1 & 2 & 3 \\ \hline
        4 & 5 & 6 \\ \hline
        7 & 8 & 9 \\
        \hline
    \end{tabular}
\end{table*}

\end{document}
3
  • Thank you. Frustrating. That means I'm gonna have to find another way to make the List of Tables spread over the whole page. Mar 22, 2017 at 15:34
  • As it turns out, I didn't have to copy the whole file after all. Mar 22, 2017 at 15:36
  • Brilliant, John. I appreciate your spending time on this. Works perfectly. So, fellow Trojan, thank you. Mar 22, 2017 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .