3

At a couple of places in my bibliography, I cite an original work and a modern edition. The date for the old edition is the same as the origdate for the new edition. That shows up in the bibliography as:

Hume, David. (1748a) 2007. An Enquiry Concerning Human Understanding. Edited by Peter F. Millican. Oxford: Oxford University Press.
---. 1748b. An Enquiry Concerning Human Understanding. London: A. Millar.

But that's not quite what I want --- I'd like to get rid of the disambiguating suffix. I'd prefer the following:

Hume, David. 1748. An Enquiry Concerning Human Understanding. London: A. Millar.
---. (1748) 2007. An Enquiry Concerning Human Understanding. Edited by Peter F. Millican. Oxford: Oxford University Press.

Is there any way to remove the suffix in such cases? (As a bonus, is there any way to have it so that the original work sorts first, as shown above?)

Here's a MWE:

\documentclass{article}

\usepackage[backend=biber,authordate,cmsdate=both]{biblatex-chicago}

\begin{filecontents*}{bibliography.bib}
  @Book{hume48:_philos_essay_concer_human_under,
    author =       {David Hume},
    title =        {An Enquiry Concerning Human Understanding},
    date =      1748,
    publisher = {A. Millar},
    location =  {London}}

  @Book{hume07:_enquir_concer_human_under,
    author =       {David Hume},
    title =        {An Enquiry Concerning Human Understanding},
    date =      2007,
    origdate =     1748,
    editor =    {Peter F. Millican},
    publisher = {Oxford University Press},
    location =  {Oxford}}
}
\end{filecontents*}

\addbibresource{bibliography.bib}


\begin{document}

\nocite{*}
\printbibliography

\end{document}
1

Currently, no matter what settings we apply, Biber only considers one year (and one year only) for extrayear disambiguation. Which field that is can be controlled by \DeclareLabeldate. But that means that for extryear purposes Biber never takes into account additional year fields.

Consider a situation where you have three works by the same author

  1. the first work has date = {2000},
  2. the second work has date = {1960}, and
  3. the third work has origdate = {1960} and date = {2000}.

No matter what you do, in this situation you will end up with an extrayear disambiguation. If origdate is preferred to date in \DeclareLabeldate you will get

2000, 1960a, (1960b) 2000

for the three works.

If date is preferred you get

2000a, 1960, (1960) 2000b

This means that with current features we will have to resort to tricks in order to get

2000, 1960, (1960) 2000

which is technically not ambiguous, but bordering on ambiguous, so I would urge you to accept what biblatex-chicago produces by default.


Since Biber assigns the extrayear, we have to find a way to tell Biber not to assign extrayear in this case. David Purton's solution of clearing the extrayear field works in this case, but as he noted in general one might run into trouble, if there is another work by Hume from 1748.

A different way that will work as long there is no second work with date = 2007, origdate = 1748, (so logically that event should be more likely then the event that there is a second work from 1748) is to make Biber ignore the work in question for extrayear purposes with options = {skiplab}.

@book{hume07:_enquir_concer_human_under,
  author    = {David Hume},
  title     = {An Enquiry Concerning Human Understanding},
  date      = 2007,
  origdate  = 1748,
  editor    = {Peter F. Millican},
  publisher = {Oxford University Press},
  location  = {Oxford},
  options   = {skiplab},
}

In the MWE then your entries even sort as expected, though that is not guaranteed in all settings, so you might have to resort to sortyear as explained by David in his answer.

5
  • Nice. I didn't realise skiplab would have this effect. This is a better answer. Mar 24 '17 at 13:10
  • @DavidPurton I was lucky to have used skiplab just a few days ago and I feared it would do more that I wanted it to, but that fear turned out to be unsubstantiated. The answer is only marginally 'better' though, since it too will fail as soon as we have more entries with a similar date profile.
    – moewe
    Mar 24 '17 at 13:17
  • Nice! It sounds like preferring date to origdate is the best option. I'm running into a strange problem, though: if I compile my MWE with \DeclareLabeldate{\field{date} \field{origdate}} in the preamble, the dates come out as 1748 and (2007) 2007. If I use \DeclareLabeldate{\field{origdate} \field{date}}, things come out as expected (1748a and (1748b) 2007). Any ideas?
    – arapede
    Mar 25 '17 at 17:18
  • @arapede biblatex-chicago with cmsdate=both doesn't seem to be cut out for \DeclareLabeldate{\field{date} \field{origdate}}. There is a lot of special things going on when it comes to date and origdate in biblatex-chicago, you can't just switch without modifying lots of other code. The first part of the answer was mainly meant to explain why things don't work as expected, it was not mean to give an answer. You could try cmsdate=off, though.
    – moewe
    Mar 25 '17 at 17:25
  • Ah, got it --- I'll go with skiplab. Great answer.
    – arapede
    Mar 25 '17 at 18:58
1

Here's an answer that clears the extrayear field when you specify in the bib entry. It doesn't change the extrayear field though.

Therefore, this is not quite a perfect answer because it would give potentially wrong output if you had another work by Hume also published in 1748. As the extrayear field is created by biber, I don't know how to deal with this.

With that in mind, this is possibly a fairly rare occurrence, so give this a go.

You can control the order using the sortyear field.

I remove the extrayear field with a new entry option (useextrayear=false) which is checked at every citation and bibliography entry.

\documentclass{article}

\usepackage[backend=biber,authordate,cmsdate=both]{biblatex-chicago}

\usepackage{filecontents}
\begin{filecontents}{bibliography.bib}
  @Book{hume48:_philos_essay_concer_human_under,
    author =       {David Hume},
    title =        {An Enquiry Concerning Human Understanding},
    date =      1748,
    publisher = {A. Millar},
    location =  {London},
    sortyear = {1748a},
    options = {useextrayear=false}
    }

  @Book{hume07:_enquir_concer_human_under,
    author =       {David Hume},
    title =        {An Enquiry Concerning Human Understanding},
    date =      2007,
    origdate =     1748,
    editor =    {Peter F. Millican},
    publisher = {Oxford University Press},
    location =  {Oxford},
    sortyear = {1748b},
    options = {useextrayear=false}
    }
}
\end{filecontents}

\addbibresource{bibliography.bib}

\pagestyle{empty}

\makeatletter
\newtoggle{blx@useextrayear}
\toggletrue{blx@useextrayear}
\DeclareEntryOption[boolean]{useextrayear}[true]{%
  \settoggle{blx@useextrayear}{#1}}
\AtEveryCitekey{\iftoggle{blx@useextrayear}{}{\clearfield{extrayear}}}
\AtEveryBibitem{\iftoggle{blx@useextrayear}{}{\clearfield{extrayear}}}
\makeatother

\begin{document}

\autocite{hume07:_enquir_concer_human_under}

\autocite{hume48:_philos_essay_concer_human_under}

\printbibliography

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.