1

This question already has an answer here:

Consider the bibliography file biblio.bib

@article{Sutter-TheFreeLunchIsOver,
  author={Herb Sutter},
  title={The Free Lunch Is Over: A Fundamental Turn Toward Concurrency in Software},
  journal={Dr.\ Dobb's Journal},
  year={2005},
  volume={30},
  number={3},
  month= mar
}

and the latex file main.tex

\documentclass{article}
%\documentclass{IEEEtran}
\usepackage[backend=biber,bibstyle=ieee]{biblatex}
\addbibresource{biblio.bib}
\begin{document}
\cite{Sutter-TheFreeLunchIsOver}
\printbibliography
\end{document}

No matter whether we are using the article class or the ieeetran class, a "no." without a number is printed to the PDF obtained from pdflatex main && biber main && pdflatex main:

the output of pdflatex main && biber main && pdflatex main

I have no idea why the number entry (number={3}) in the .bib file is ignored and whether the printing of "no." without a number is a bug or a feature. Apparently, it is hard to turn off, since the biblatex-ieee documentation also has this bug/feature as of March 2, 2017.

In any case, I'd like to avoid "no., " altogether or to have "no. 3," instead. Any help?

marked as duplicate by moewe biblatex Mar 22 '17 at 8:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

It's a bug of the style. The current definition in ieee.bbxis:

\renewbibmacro*{volume+number+eid}{%
  \printfield{volume}%
  \newunit
  \bibstring{number}%
  \newunit
  \printfield{eid}%
}

The \bibstring is wrong. It should be \printfield

So add the following definition to your header (after loading biblatex).

\renewbibmacro*{volume+number+eid}{%
  \printfield{volume}%
  \newunit
  \printfield{number}%
  \newunit
  \printfield{eid}%
}

The author is informed.

  • @LeonMeier: The author uploads an update. In the next few days it should be available via your package manager. – Marco Daniel Mar 22 '17 at 11:42