4

MWE:

\documentclass{exam}
   \setlength\parindent{100pt}

\printanswers
\begin{document}

   \begin{questions}
      \question Please help me.
         \begin{parts}
            \part Will this produce correctly indented paragraphs?


        \begin{solution}
           This is the first paragraph of the solution lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum. \par
           This is the second paragraph dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est.
        \end{solution}

        \part No difference with blank lines?
        \begin{solution}
           This is the first paragraph of the solution lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum.

           This is the second paragraph dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est.
        \end{solution}

     \end{parts}
   \end{questions}
\end{document}

The paragraphs of the solutions are not properly indented. How can I get paragraphs to indent correctly in the solution environment?

I've tried setting the indent length, and I've tried using both par and a blank line to get a paragraph. I've also had a look at the documentation for the class, but I didn't see anything that adressed my question.

3
  • 2
    If you mean indentation inside the solution environment, you may need to set the length there. I don't use the class, so maybe there's a class-specific way to do it. If not, then \usepackage{etoolbox} \AtBeginEnvironment{solution}{\setlength\parindent{100pt}} may do the trick.
    – jon
    Mar 23, 2017 at 1:55
  • This fix works! :D But please forgive me if I wait for another answer that may be more elegant or that doesn't require loading more packages. :) Alternatively, feel free to write this as an answer and if nothing else comes up I'll select it as an answer. ;)
    – jamesh625
    Mar 23, 2017 at 2:29
  • Maybe it's worth an upvote, but if an exam-specific answer is given, that's probably worth the checkmark....
    – jon
    Mar 23, 2017 at 4:24

1 Answer 1

3

One way to adjust (globally) the spacing of the solution environment is to use etoolbox, which provides the \AtBeginEnvironment command. So:

\documentclass{exam}
\usepackage{etoolbox}
\AtBeginEnvironment{solution}{\setlength{\parindent}{100pt}}

\printanswers

\begin{document}

\begin{questions}
\question Please help me.

  \begin{parts}
  \part Will this produce correctly indented paragraphs?

    \begin{solution}
    This is the first paragraph of the solution lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum lorem ipsum.

    This is the second paragraph dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est dolorum est.
    \end{solution}

  \end{parts}
\end{questions}
\end{document}
2
  • 2
    Very nice. This is needed because the questions, parts, subparts, and subsubparts environments are all implemented as LaTeX list environments, which set the parindent to 0pt. Mar 23, 2017 at 5:07
  • It's nice to know the reason why!
    – jamesh625
    Mar 23, 2017 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .