1

I am trying to draw the following reaction

equilibrium reaction

but as you can see, the single bond does not start at the lower right corner of the carbon-13-labeled atom (^{13}C) but instead somewhere below that atom. If I remove the subscript "13", the positioning is correct, but in this specific reaction, the selective carbon-13-labels are important.

Does anybody have an idea of how to accomplish this? I tried \lbox and such things, but the behaviour is always the same...

MWE:

\documentclass{article}
\usepackage{chemfig,chemmacros}
\begin{document}
\begin{equation}
\begin{split}    
\schemestart
    \setatomsep{2em}\chemfig*{^{-}OO{\color{blue}^{13}C}-[::-30,,3]=[::60]-[::-60]{\color{blue}^{13}C}OO^{-}} \arrow{0}[,0] \+ \chemfig*{H_2O}  
    \arrow{<=>[\footnotesize fumarase]}[,1.3]
    \setatomsep{2em}\chemfig*{^{-}OO{\color{blue}^{13}C}-[::-30]-[::60](<:[::60]OH)-[::-60]{\color{blue}^{13}C}OO^{-}} 
\schemestop
\end{split}
\end{equation} 
\end{document}

Thank you to any suggestions of how to tackle this problem.

2

There's no need for \quad or any other lengths. You just need to tell chemfig the right thing. The trick can be found in the the manual part III (Advanced Usage) section 1 (Separating Atoms):

The character “|” forces splitting of the atom when it is encountered. Thus we can write C|{(CH_3)_3} to ensure that ChemFig separates just two atoms here: “C” and “{(CH_3)_3}”.

For your case that means instead of writing {\color{blue}^{13}C}-[::-30,,3] where {\color{blue}^{13}C} is one atom write \color{blue}^{13}|{\color{blue}C}-[::-30,,4]:

\documentclass{article}
\usepackage{chemfig}

\begin{document}

\begin{center}
  \setatomsep{2em}
  \schemestart
    \chemfig*{
      ^{-}OO\color{blue}^{13}|{\color{blue}C}
      -[::-30,,4]=[::60]-[::-60]
      \color{blue}^{13}|{\color{blue}C}OO^{-}}
      \arrow{0}[,0]
      \+ \chemfig*{H_2O}  
      \arrow{<=>[\footnotesize fumarase]}[,1.3]
      \chemfig*{
        ^{-}OO\color{blue}^{13}|{\color{blue}C}
        -[::-30]-[::60](<:[::60]OH)-[::-60]
        \color{blue}^{13}|{\color{blue}C}OO^{-}
      }
  \schemestop
\end{center}

\end{document}

enter image description here

BTW: it is rather strange to put the chemical scheme inside a split environment inside equation. I used center which seemed much more natural to me. Maybe you wanted the equation numbering. But then an equation suffices:

\documentclass{article}
\usepackage[margin=1in]{geometry}
\usepackage{chemfig}

\begin{document}

\begin{equation}
  \setatomsep{2em}
  \schemestart
    \chemfig*{
      ^{-}OO\color{blue}^{13}|{\color{blue}C}
      -[::-30,,4]=[::60]-[::-60]
      \color{blue}^{13}|{\color{blue}C}OO^{-}}
      \arrow{0}[,0]
      \+ \chemfig*{H_2O}  
      \arrow{<=>[\footnotesize fumarase]}[,1.3]
      \chemfig*{
        ^{-}OO\color{blue}^{13}|{\color{blue}C}
        -[::-30]-[::60](<:[::60]OH)-[::-60]
        \color{blue}^{13}|{\color{blue}C}OO^{-}
      }
  \schemestop
\end{equation}

\end{document}
|improve this answer|||||
  • Thank you for your answer, this is of course the correct way to do it. In this case, you can even leave out the ,,4 part in the code. I have used the split environment because I wanted the numbering and by adding the split part inside the equation part, the numbering vertically shifts down to the center of the equation instead of being on the same vertical level as the first OOC-group at the very left. – stephanmunich Mar 24 '17 at 9:56
  • Now I only have the problem that putting the names underneath the molecules, i.e. fumarate, waterand malatedoes not align them vertically on the same level, even if I use chemnameinitwith the largest molecule, as suggested in the documentation, do you have a suggestion of how to solve this problem as well? Thanks in advance! – stephanmunich Mar 24 '17 at 10:02
  • The number is not placed under the scheme if you have smaller margins than the exceedingly large margins of the standard article class (cf. tex.stackexchange.com/questions/71172/…) – cgnieder Mar 24 '17 at 10:15
  • For your other problem I suggest you ask a new question – cgnieder Mar 24 '17 at 10:16
0

Um, first of all, the MWE that you posted can't be compiled because you forgot to wrap it in \begin{document}...\end{document}. Regarding your issue; this is extremely easy to solve. All you have to do is "lure" the positioning of bonds with some extra space. In this case, I used \quad, but you can also use smaller and larger amounts of negative (\!) or positive (\,, \;, \. etc.) space so the picture will fit your needs. One little note though - my original (1) is misplaced because of my margin, which is too small to fit the length of your chemfig. I'm sure you'll be able to accommodate this detail yourself (it's your LaTeX compiler, computer and setup, after all). Because I don't want the document to look ugly I extended the page width with \textwidth. Anyway, the code.

\documentclass{article}
\usepackage{chemfig,chemmacros}

\textwidth = 400pt

\begin{document}

\begin{equation}
\begin{split}    
\schemestart
\setatomsep{2em}\chemfig*{^{-}OO{\color{blue}^{13}C \quad}-[::-30,,3]=[::60]-[::-60]{\color{blue}^{13}C}OO^{-}} \arrow{0}[,0] \+ \chemfig*{H_2O}  
\arrow{<=>[\footnotesize fumarase]}[,1.3]
\setatomsep{2em}\chemfig*{^{-}OO{\color{blue}^{13}C \quad}-[::-30]-[::60](<:[::60]OH)-[::-60]{\color{blue}^{13}C}OO^{-}} 
\schemestop
\end{split}
\end{equation}

\end{document}

And here is the result.

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.